summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfielding <fielding@13f79535-47bb-0310-9956-ffa450edef68>2001-05-12 03:41:53 +0000
committerfielding <fielding@13f79535-47bb-0310-9956-ffa450edef68>2001-05-12 03:41:53 +0000
commit00286f3d675ebf8d7524f2761f55a3613afd2ca0 (patch)
tree13748451233fedbe86470920a608d16dc5ef0b85 /configure.in
parenteb496b2f784c1682338307a511b380bec67b1f79 (diff)
downloadlibapr-00286f3d675ebf8d7524f2761f55a3613afd2ca0.tar.gz
Allow LTFLAGS to be overridden by the configure command-line
(default="--silent") and introduce LT_LDFLAGS. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61616 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 13 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 63bb2bf7f..f61e03488 100644
--- a/configure.in
+++ b/configure.in
@@ -100,6 +100,9 @@ case "$host_alias" in
;;
*) dnl libtoolize requires that the following not be indented
AC_PROG_LIBTOOL
+ if test "x$LTFLAGS" = "x"; then
+ LTFLAGS='--silent'
+ fi
;;
esac
@@ -107,21 +110,23 @@ AC_ARG_ENABLE(libtool, [--with-libtool use libtool to link the library],
[ use_libtool=$withval ], [ use_libtool="yes" ] )
if test "x$use_libtool" = "xyes"; then
- lt_compile="\$(LIBTOOL) --mode=compile \$(LTFLAGS) \$(COMPILE) -c \$< && touch \$@"
- link="\$(LIBTOOL) --mode=link \$(LTFLAGS) \$(COMPILE) \$(ALL_LDFLAGS) -o \$@"
- so_ext="lo"
- lib_target="-rpath \$(libdir) \$\$objects"
+ lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -c $< && touch $@'
+ link='$(LIBTOOL) $(LTFLAGS) --mode=link $(LT_LDFLAGS) $(COMPILE) $(ALL_LDFLAGS) -o $@'
+ so_ext='lo'
+ lib_target='-rpath $(libdir) $$objects'
else
- lt_compile="\$(COMPILE) -c \$<"
- link="\$(AR) cr \$(TARGET_LIB) \$\$objects; \$(RANLIB) \$(TARGET_LIB)"
- so_ext="o"
- lib_target=""
+ lt_compile='$(COMPILE) -c $<'
+ link='$(AR) cr $(TARGET_LIB) $$objects; $(RANLIB) $(TARGET_LIB)'
+ so_ext='o'
+ lib_target=''
fi
AC_SUBST(lt_compile)
AC_SUBST(link)
AC_SUBST(so_ext)
AC_SUBST(lib_target)
+AC_SUBST(LTFLAGS)
+AC_SUBST(LT_LDFLAGS)
dnl #----------------------------- Checks for compiler flags
nl='