summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-02-19 23:00:39 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-02-19 23:00:39 +0000
commitfd0f4ff5ddff6c330b467f1cb06911609d130606 (patch)
treecb78a1fdb2e07adc6979cec0f36a03282f28b6c5 /configure.in
parentb9e9f8a1befdfd4dd3cb8043699cf7a70bef9bdf (diff)
downloadlibapr-fd0f4ff5ddff6c330b467f1cb06911609d130606.tar.gz
Cope with BSDi installations where the default make has been
replaced with GNU make. Submitted by: Joe Orton <joe@manyfish.co.uk> Reviewed by: Jeff Trawick git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61262 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d464792b4..797bb69f6 100644
--- a/configure.in
+++ b/configure.in
@@ -920,7 +920,13 @@ dnl BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
dnl
case "$host_alias" in
*bsdi*)
- INCLUDE_RULES=".include \"$apr_builders/rules.mk\""
+ # Check whether they've installed GNU make
+ if make --version > /dev/null 2>&1; then
+ INCLUDE_RULES="include $apr_builders/rules.mk"
+ else
+ # BSDi make
+ INCLUDE_RULES=".include \"$apr_builders/rules.mk\""
+ fi
;;
*)
INCLUDE_RULES="include $apr_builders/rules.mk"