summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2001-01-05 21:22:19 +0000
committerrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2001-01-05 21:22:19 +0000
commit5a150be091cd03e5107e70d937ef1e8bbcd88cfd (patch)
tree29ae38adf72f64a843e84f15c65642fba211e710 /configure.in
parentc26d173c9df08e7510c9272eaefaca2a5046cbee (diff)
downloadlibapr-5a150be091cd03e5107e70d937ef1e8bbcd88cfd.tar.gz
Simplify the logic for TCP cork on Linux. Basically, instead of grepping
through the system header files, trying to find TCP_CORK, we just check if sendfile was found. If so, but we couldn't find TCP_CORK, we define it ourselves. This is the same logic that the C files used to use, so it should be much more stable. Submitted by: Jeff Trawick <trawickj@bellsouth.net> git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61025 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3deefa371..4b7503ee3 100644
--- a/configure.in
+++ b/configure.in
@@ -799,10 +799,10 @@ if test "x$ac_cv_define_TCP_CORK" = "xyes"; then
else
case $OS in
*linux*)
- AC_EGREP_HEADER(TCP_CORK, linux/socket.h, [
- apr_tcp_nopush_flag="3"
- have_corkable_tcp="1"
- ])
+ if test "x$sendfile" = "x1"; then
+ apr_tcp_nopush_flag="3"
+ have_corkable_tcp="1"
+ fi
;;
*)
;;