summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2002-08-03 20:53:06 +0000
committerwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2002-08-03 20:53:06 +0000
commit42400cd4e3b21fa548906cd001b428683ea7644c (patch)
tree64cce3c4659bd146e8fd4f02f566e1a4669517cc /configure.in
parentb1ecb6fdaaec5bd17ca7353e546ebf66276fb208 (diff)
downloadlibapr-42400cd4e3b21fa548906cd001b428683ea7644c.tar.gz
Fix two problems... if this pid/off are longlongs, WTF aren't we following
the identical semantics to our earlier apr_int32_fmt_t construction? And let us fall gracefully into strtoq when applicable. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@63783 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8e2f8522c..6abad40e5 100644
--- a/configure.in
+++ b/configure.in
@@ -1142,7 +1142,7 @@ if test "$ac_cv_sizeof_off_t" = "$ac_cv_sizeof_int"; then
elif test "$ac_cv_sizeof_off_t" = "$ac_cv_sizeof_long"; then
off_t_fmt='#define APR_OFF_T_FMT "ld"'
elif test "$ac_cv_sizeof_off_t" = "$ac_cv_sizeof_long_long"; then
- off_t_fmt='#define APR_OFF_T_FMT "qd"'
+ off_t_fmt='#define APR_OFF_T_FMT $int64_t_fmt'
else
off_t_fmt='#error Can not determine the proper size for off_t'
fi
@@ -1154,7 +1154,7 @@ if test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_int"; then
elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_long"; then
pid_t_fmt='#define APR_PID_T_FMT "ld"'
elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_long_long"; then
- pid_t_fmt='#define APR_PID_T_FMT "qd"'
+ pid_t_fmt='#define APR_PID_T_FMT $int64_t_fmt'
else
pid_t_fmt='#error Can not determine the proper size for pid_t'
fi
@@ -1217,6 +1217,12 @@ AC_CHECK_FUNCS(strstr, have_strstr="1", have_strstr="0")
AC_CHECK_FUNCS(memchr, have_memchr="1", have_memchr="0")
AC_CHECK_FUNCS($int64_strfn, have_int64_strfn="1", have_int64_strfn="0")
+dnl #----------------------------- We have a fallback position
+if test ("$have_int64_strfn" = "0") -a ("int64_strfn" = "strtoll"); then
+ int64_strfn = "strtoq"
+ AC_CHECK_FUNCS($int64_strfn, have_int64_strfn="1", have_int64_strfn="0")
+fi
+
AC_SUBST(have_strnicmp)
AC_SUBST(have_strncasecmp)
AC_SUBST(have_stricmp)