summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2005-08-24 12:40:33 +0000
committerjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2005-08-24 12:40:33 +0000
commitf707d730e5dc892904023c036ba48f1b266fdfc5 (patch)
treede780962240230e3d8695569e53f0c60104ffe1e /configure.in
parent175b379097bf1f8c76fb6b4c12bcbffa7f7f5e3d (diff)
downloadlibapr-f707d730e5dc892904023c036ba48f1b266fdfc5.tar.gz
* configure.in: Check for libefence after threads in case libefence
depends on libpthread. PR: 34806 git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@239640 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 19 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 0da0554dd..9115013a0 100644
--- a/configure.in
+++ b/configure.in
@@ -319,23 +319,6 @@ AC_ARG_ENABLE(pool-debug,
fi
])
-dnl Electric Fence malloc checker.
-dnl --with-efence specifies the path to Electric Fence
-AC_ARG_WITH(efence,
- [ --with-efence[[=DIR]] path to Electric Fence installation],
- [ apr_efence_dir="$withval"
- if test "$apr_efence_dir" != "yes"; then
- APR_ADDTO(LDFLAGS,[-L$apr_efence_dir/lib])
- if test "x$apr_platform_runtime_link_flag" != "x"; then
- APR_ADDTO(LDFLAGS,
- [$apr_platform_runtime_link_flag$apr_efence_dir/lib])
- fi
- fi
- AC_CHECK_LIB(efence, malloc,
- [ APR_ADDTO(LIBS,-lefence) ],
- [ AC_MSG_ERROR(Electric Fence requested but not detected) ])
- ])
-
if test "$host" = "i586-pc-beos"; then
AC_ARG_ENABLE(malloc-debug,[ --enable-malloc-debug Switch on malloc_debug for BeOS],
APR_REMOVEFROM(CFLAGS, -O2)
@@ -643,6 +626,25 @@ else
echo "APR will be non-threaded"
fi
+dnl Electric Fence malloc checker.
+dnl --with-efence specifies the path to Electric Fence.
+dnl This test should remain after the threads checks since libefence
+dnl may depend on libpthread.
+AC_ARG_WITH(efence,
+ [ --with-efence[[=DIR]] path to Electric Fence installation],
+ [ apr_efence_dir="$withval"
+ if test "$apr_efence_dir" != "yes"; then
+ APR_ADDTO(LDFLAGS,[-L$apr_efence_dir/lib])
+ if test "x$apr_platform_runtime_link_flag" != "x"; then
+ APR_ADDTO(LDFLAGS,
+ [$apr_platform_runtime_link_flag$apr_efence_dir/lib])
+ fi
+ fi
+ AC_CHECK_LIB(efence, malloc,
+ [ APR_ADDTO(LIBS,-lefence) ],
+ [ AC_MSG_ERROR(Electric Fence requested but not detected) ])
+ ])
+
AC_CHECK_FUNCS(sigsuspend, [ have_sigsuspend="1" ], [ have_sigsuspend="0" ])
AC_CHECK_FUNCS(sigwait, [ have_sigwait="1" ], [ have_sigwait="0" ])
dnl AC_CHECK_FUNCS doesn't work for this on Tru64 since the function