summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2006-03-10 22:04:07 +0000
committerwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2006-03-10 22:04:07 +0000
commit93ddbc7d4644b8ff75e21a905fcb947414337cf7 (patch)
tree21277ea03554a608518e24f5a5bd66db863add04 /configure.in
parente0e5daa88c522322edf79f98af960be2ea09bef2 (diff)
downloadlibapr-93ddbc7d4644b8ff75e21a905fcb947414337cf7.tar.gz
One more evolution of the uuid header detection code.
On Solaris, uuid/uuid.h defined uuid_generate, and itself includes sys/uuid.h which only defined the uuid_t. Therefore prefer the broadest uuid.h, followed by uuid/uuid.h, and only if those fail, fall back on sys/uuid.h which may contain nothing beyond the sys types of uuid_t entities. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@384930 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 15850a195..3f1a99cbb 100644
--- a/configure.in
+++ b/configure.in
@@ -1804,7 +1804,7 @@ AC_SUBST(rand)
dnl ----------------------------- Checking for UUID Support
echo "${nl}Checking for OS UUID Support..."
-AC_CHECK_HEADERS(uuid.h sys/uuid.h uuid/uuid.h, break)
+AC_CHECK_HEADERS(uuid.h uuid/uuid.h sys/uuid.h, break)
apr_revert_save_LIBS=$LIBS
@@ -1820,20 +1820,20 @@ AC_CHECK_FUNCS(uuid_create uuid_generate)
AC_CACHE_CHECK([for os uuid usability], [apr_cv_osuuid], [
# Ensure this test closely mirrors misc/unix/rand.c!
-uuid_includes=" ${nl}
-#if defined(HAVE_SYS_TYPES_H) ${nl}
-#include <sys/types.h> ${nl}
-#endif ${nl}
-#if defined(HAVE_UNISTD_H) ${nl}
-#include <unistd.h> ${nl}
-#endif ${nl}
-#if defined(HAVE_UUID_H) ${nl}
-#include <uuid.h> ${nl}
-#elif defined(HAVE_SYS_UUID_H) ${nl}
-#include <sys/uuid.h> ${nl}
-#elif defined(HAVE_UUID_UUID_H) ${nl}
-#include <uuid/uuid.h> ${nl}
-#endif ${nl}
+uuid_includes="
+#if defined(HAVE_SYS_TYPES_H)
+#include <sys/types.h>
+#endif
+#if defined(HAVE_UNISTD_H)
+#include <unistd.h>
+#endif
+#if defined(HAVE_UUID_H)
+#include <uuid.h>
+#elif defined(HAVE_UUID_UUID_H)
+#include <uuid/uuid.h>
+#elif defined(HAVE_SYS_UUID_H)
+#include <sys/uuid.h>
+#endif
"
apr_cv_osuuid=no
if test $ac_cv_func_uuid_create = yes; then