summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin <martin@13f79535-47bb-0310-9956-ffa450edef68>2005-06-10 14:10:40 +0000
committermartin <martin@13f79535-47bb-0310-9956-ffa450edef68>2005-06-10 14:10:40 +0000
commit724131c4fca3df0cb8aab5fba9c734c7ff9b0e23 (patch)
treee48166f78349d3f553a0adc538d35a5d343e6d5a /configure.in
parent1741d023c70696ddd1d10a9734c4f2e3755fea53 (diff)
downloadlibapr-724131c4fca3df0cb8aab5fba9c734c7ff9b0e23.tar.gz
Fix code which handles FreeBSD release numbers
1.23.4-RELEASE => 1234 1.2.3-RELEASE => 1023 1.2-RELEASE => 1020 to accomodate for <onedigit>.<twodigits>[.<onedigit>] numbers. Previously, configure would complain: /home/martin/apr/configure: line 27912: test: 4.11-STABLE: integer expression expected git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@189962 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ae5fa6e9f..9b78dd59f 100644
--- a/configure.in
+++ b/configure.in
@@ -516,8 +516,8 @@ AC_SUBST(INSTALL_SUBDIRS)
# comparisons.
case $host in
*freebsd*)
- # 3.4-RELEASE: 340 4.1.1-RELEASE: 411
- os_version=`uname -r | sed -e 's/\(.\)\.\(.\)\.\(.\).*/\1\2\3/' | sed -e 's/\(.\)\.\(.\)\-.*/\1\20/'`
+ # 3.4-RELEASE: 3040 4.2.1-RELEASE: 4021 4.11-STABLE: 4110
+ os_version=`uname -r | sed -e 's/^\([1-9]\)\.\([0-9]\)\.\([0-9]\).*/\10\2\3/' -e 's/^\([1-9]\)\.\([0-9][0-9]\)\.\([0-9]\).*/\1\2\3/' -e 's/^\([1-9]\)\.\([0-9][0-9]\)-.*/\1\20/' -e 's/^\([1-9]\)\.\([0-9][0-9]\)-.*/\1\20/' -e 's/\([1-9]\)\.\([0-9]\)\-.*/\10\20/'`
;;
*linux*)
os_version=`uname -r | sed -e 's/\(.\)\.\(.\)\.\(.\).*/\1\2\3/'`
@@ -900,7 +900,7 @@ AC_ARG_WITH(sendfile, [ --with-sendfile Override decision to use sendfi
orig_sendfile=$sendfile
case $host in
*freebsd*)
- if test $os_version -le "410"; then
+ if test $os_version -le "4010"; then
if test "$threads" = "1"; then
sendfile="0"
fi