summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2005-02-04 17:42:07 +0000
committerjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2005-02-04 17:42:07 +0000
commit26c6d90dfa6f008eaf2935605baacb97513a8724 (patch)
tree91b7816be094e19cbfc9eb22ab0bdd70b08ad931 /configure.in
parent9489138f7fa0d80858e071dc0d4daef2e0212211 (diff)
downloadlibapr-26c6d90dfa6f008eaf2935605baacb97513a8724.tar.gz
* configure.in: For Linux/s390, print size_t as unsigned long int and
ssize_t as signed long int (previously signed long int and signed int respectively). git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@151378 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1f910293e..aa8442b5f 100644
--- a/configure.in
+++ b/configure.in
@@ -1321,7 +1321,10 @@ fi
# you can override our decision below.
case $host in
s390*linux*)
- size_t_fmt='#define APR_SIZE_T_FMT "ld"'
+ # uniquely, the 31-bit Linux/s390 uses "unsigned long int"
+ # for size_t rather than "unsigned int":
+ size_t_fmt='#define APR_SIZE_T_FMT "lu"'
+ ssize_t_fmt='#define APR_SSIZE_T_FMT "ld"'
;;
*-os2*)
size_t_fmt='#define APR_SIZE_T_FMT "lu"'