summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2007-09-25 14:38:00 +0000
committerjorton <jorton@13f79535-47bb-0310-9956-ffa450edef68>2007-09-25 14:38:00 +0000
commit0520ee6743210b627aa64c881a779aa36f5fa37c (patch)
tree382959ec98ef4deb2cc1c1f36eed5c26fa2e7a8e /configure.in
parentdff0b4d63a4896e7cb1d716d6af6648bf3d64aa3 (diff)
downloadlibapr-0520ee6743210b627aa64c881a779aa36f5fa37c.tar.gz
* configure.in, Makefile.in: Define the libtool versioning hint in the
Makefile rather than hard-coding in the (shared) apr_rules.mk. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@579264 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c1059bdf1..a13e8ee54 100644
--- a/configure.in
+++ b/configure.in
@@ -199,7 +199,7 @@ AC_ARG_WITH(libtool, [ --without-libtool avoid using libtool to link the
if test "x$use_libtool" = "xyes"; then
lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
+ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) \$(LT_VERSION) \$(ALL_LDFLAGS) -o \$@"
so_ext='lo'
lib_target='-rpath $(libdir) $(OBJECTS)'
export_lib_target='-rpath \$(libdir) \$(OBJECTS)'
@@ -227,6 +227,7 @@ AC_SUBST(export_lib_target)
AC_SUBST(shlibpath_var)
AC_SUBST(LTFLAGS)
AC_SUBST(LT_LDFLAGS)
+AC_SUBST(LT_VERSION)
dnl ----------------------------- Checks for compiler flags
nl='