summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 772ff7f..12870bd 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -2,6 +2,10 @@ MAN5 = depmod.d.5 modprobe.d.5 modules.dep.5
MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
MAN_STUB = modules.dep.bin.5
+AM_V_XSLT = $(AM_V_XSLT_$(V))
+AM_V_XSLT_ = $(AM_V_XSLT_$(AM_DEFAULT_VERBOSITY))
+AM_V_XSLT_0 = @echo " XSLT " $@;
+
if BUILD_TOOLS
dist_man_MANS = $(MAN5) $(MAN8) $(MAN_STUB)
modules.dep.bin.5: modules.dep.5
@@ -11,10 +15,11 @@ EXTRA_DIST = $(MAN5:%.5=%.xml) $(MAN8:%.8=%.xml)
XSLTPROC_FLAGS = \
--nonet \
+ --stringparam man.output.quietly 1 \
--param funcsynopsis.style "'ansi'"
CLEANFILES = $(dist_man_MANS)
%.5 %.8: %.xml
- $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_FLAGS) \
+ $(AM_V_XSLT)$(XSLTPROC) $(XSLTPROC_FLAGS) \
http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<