summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 71f6d34..f709c9f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,7 +8,7 @@ source = "vcs"
[project]
name = "jsonschema"
description = "An implementation of JSON Schema validation for Python"
-requires-python = ">=3.7"
+requires-python = ">=3.8"
license = {text = "MIT"}
keywords = ["validation", "data validation", "jsonschema", "json"]
authors = [
@@ -21,7 +21,6 @@ classifiers = [
"License :: OSI Approved :: MIT License",
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
@@ -32,8 +31,10 @@ classifiers = [
dynamic = ["version", "readme"]
dependencies = [
- "attrs>=17.4.0",
- "pyrsistent>=0.14.0,!=0.17.0,!=0.17.1,!=0.17.2",
+ "attrs>=22.2.0",
+ "jsonschema-specifications>=2023.03.4",
+ "referencing>=0.24.4",
+ "rpds-py>=0.6.1",
"importlib_metadata;python_version<'3.8'",
"typing_extensions;python_version<'3.8'",