summaryrefslogtreecommitdiff
path: root/json-glib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'json-glib/tests/Makefile.am')
-rw-r--r--json-glib/tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/json-glib/tests/Makefile.am b/json-glib/tests/Makefile.am
new file mode 100644
index 0000000..31e46d4
--- /dev/null
+++ b/json-glib/tests/Makefile.am
@@ -0,0 +1,24 @@
+include $(top_srcdir)/Makefile.decl
+
+INCLUDES = \
+ -g \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/json-glib \
+ $(JSON_DEBUG_CFLAGS) \
+ $(JSON_CFLAGS)
+
+noinst_PROGRAMS = $(TEST_PROGS)
+progs_ldadd = $(top_builddir)/json-glib/libjson-glib-1.0.la
+
+TEST_PROGS += array-test
+array_test_SOURCES = array-test.c
+array_test_LDADD = $(progs_ldadd)
+
+TEST_PROGS += object-test
+object_test_SOURCES = object-test.c
+object_test_LDADD = $(progs_ldadd)
+
+TEST_PROGS += node-test
+node_test_SOURCES = node-test.c
+node_test_LDADD = $(progs_ldadd)
+