summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01d37f8..ed7bc03 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -436,10 +436,12 @@ include_directories(${PROJECT_BINARY_DIR})
add_subdirectory(doc)
# uninstall
-add_custom_target(uninstall
- COMMAND cat ${PROJECT_BINARY_DIR}/install_manifest.txt | xargs rm
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-)
+if(NOT TARGET uninstall)
+ add_custom_target(uninstall
+ COMMAND cat ${PROJECT_BINARY_DIR}/install_manifest.txt | xargs rm
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+endif()
# XXX for a normal full distribution we'll need to figure out
# XXX how to build both shared and static libraries.