summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db00b04..a0f226c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -341,8 +341,8 @@ option(BUILD_DOCUMENTATION "Create and install the HTML based API documentation(
if (DOXYGEN_FOUND)
add_custom_target(doc
- COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_BINARY_DIR}/Doxyfile
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+ COMMAND ${DOXYGEN_EXECUTABLE} ${PROJECT_SOURCE_DIR}/Doxyfile
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR})
# request to configure the file
configure_file(Doxyfile Doxyfile)