summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Clark <michael@metaparadigm.com>2007-03-13 08:26:20 +0000
committerMichael Clark <michael@metaparadigm.com>2007-03-13 08:26:20 +0000
commit4504df71178fe7a0eb8e7c37fa548b7c853a800f (patch)
treeb5c804143276475f469429ad2f7e6c7de9584743 /Makefile.am
parentf0d08887b857fce1fe95a68d29eb7a07cd527d7c (diff)
downloadjson-c-4504df71178fe7a0eb8e7c37fa548b7c853a800f.tar.gz
* printbuf.c - C. Watford (christopher dot watford at gmail dot com)
Added a Win32/Win64 compliant implementation of vasprintf * debug.c - C. Watford (christopher dot watford at gmail dot com) Removed usage of vsyslog on Win32/Win64 systems, needs to be handled by a configure script * json_object.c - C. Watford (christopher dot watford at gmail dot com) Added scope operator to wrap usage of json_object_object_foreach, this needs to be rethought to be more ANSI C friendly * json_object.h - C. Watford (christopher dot watford at gmail dot com) Added Microsoft C friendly version of json_object_object_foreach * json_tokener.c - C. Watford (christopher dot watford at gmail dot com) Added a Win32/Win64 compliant implementation of strndup * json_util.c - C. Watford (christopher dot watford at gmail dot com) Added cast and mask to suffice size_t v. unsigned int conversion correctness * json_tokener.c - sign reversal issue on error info for nested object parse spotted by Johan Bj�rklund (johbjo09 at kth.se) * json_object.c - escape " in json_escape_str * Change to automake and libtool to build shared and static library Michael Clark <michael@metaparadigm.com> git-svn-id: http://svn.metaparadigm.com/svn/json-c/trunk@4 327403b1-1117-474d-bef2-5cb71233fd97
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9e86ccd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+AUTOMAKE_OPTIONS = 1.6
+
+CFLAGS = -Wall -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+
+libjson_la_LIBADD = $(JSON_LIBS)
+
+lib_LTLIBRARIES = libjson.la
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = json.pc
+
+libjsonincludedir = $(includedir)/json
+libjsoninclude_HEADERS = \
+ json.h \
+ bits.h \
+ debug.h \
+ linkhash.h \
+ arraylist.h \
+ json_util.h \
+ json_object.h \
+ json_tokener.h
+
+libjson_la_LDFLAGS = -version-info 0:1:0
+
+libjson_la_SOURCES = \
+ arraylist.c \
+ debug.c \
+ json_object.c \
+ json_tokener.c \
+ json_util.c \
+ linkhash.c \
+ printbuf.c
+
+check_PROGRAMS = test1 test2
+
+test1_SOURCES = test1.c
+test1_LDADD = $(lib_LTLIBRARIES)
+
+test2_SOURCES = test2.c
+test2_LDADD = $(lib_LTLIBRARIES)