summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Ronacher <armin.ronacher@active-4.com>2010-08-17 12:10:27 +0200
committerArmin Ronacher <armin.ronacher@active-4.com>2010-08-17 12:10:27 +0200
commit10c34da7df5e911e45537e03ed6068ad1a8712b2 (patch)
tree35a5896aaf56ccb330ed6bc2b0390c4ca1006336 /setup.py
parent53675ce87c1462d19cd7960cd80602b5457263d9 (diff)
downloadjinja2-10c34da7df5e911e45537e03ed6068ad1a8712b2.tar.gz
Documented switch to MarkupSafe
--HG-- branch : trunk
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cee83cc..f3b80b6 100644
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,17 @@ Jinja2==dev``.
import os
import sys
-from setuptools import setup
+from setuptools import setup, Extension, Feature
+from distutils.command.build_ext import build_ext
+
+debugsupport = Feature(
+ 'optional C debug support',
+ standard=False,
+ ext_modules = [
+ Extension('jinja2._debugsupport', ['jinja2/_debugsupport.c']),
+ ],
+)
+
# tell distribute to use 2to3 with our own fixers.
extra = {}
@@ -86,5 +96,6 @@ setup(
[babel.extractors]
jinja2 = jinja2.ext:babel_extract[i18n]
""",
+ features={'debugsupport': debugsupport},
**extra
)