summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Ronacher <armin.ronacher@active-4.com>2008-04-20 13:11:43 +0200
committerArmin Ronacher <armin.ronacher@active-4.com>2008-04-20 13:11:43 +0200
commitf59bac20dff640f8b4156b1a4e4331ea32cbd9af (patch)
treeb8b31bebfcbd2d096b9188a862b786b921b64665 /setup.py
parentf41d1397f652093e9b3d7978fc32e73b87eeac3b (diff)
downloadjinja2-f59bac20dff640f8b4156b1a4e4331ea32cbd9af.tar.gz
added first code for parser extensions and moved some code in speedups around
--HG-- branch : trunk
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a292d5b..a12d998 100644
--- a/setup.py
+++ b/setup.py
@@ -108,7 +108,7 @@ setup(
# in form of html and txt files it's a better idea to extract the files
zip_safe=False,
classifiers=[
- 'Development Status :: 1 - Alpha',
+ 'Development Status :: 4 Beta',
'Environment :: Web Environment',
'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
@@ -131,5 +131,9 @@ setup(
]
)
},
- extras_require={'plugin': ['setuptools>=0.6a2']}
+ extras_require={'i18n': ['Babel>=0.8']}
+ entry_points="""
+ [babel.extractors]
+ jinja2 = jinja.i18n:babel_extract[i18n]
+ """
)