summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Ronacher <armin.ronacher@active-4.com>2009-09-13 00:23:27 -0700
committerArmin Ronacher <armin.ronacher@active-4.com>2009-09-13 00:23:27 -0700
commit86b5cb531dd1b0b97ab92b4a4f8efa22a2bc071b (patch)
treeb8e2330538204e1f7d3fce235089ee115ae68516 /setup.py
parentefcc0e5ad10714a41092705b1ac4ffadbdb404e4 (diff)
downloadjinja2-86b5cb531dd1b0b97ab92b4a4f8efa22a2bc071b.tar.gz
(codename Kong, released on September 12th 2009)
--HG-- branch : trunk
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 2 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index 439ce9f..2284f2e 100644
--- a/setup.py
+++ b/setup.py
@@ -47,38 +47,9 @@ from distutils.command.build_ext import build_ext
from distutils.errors import CCompilerError, DistutilsPlatformError
-#: don't change the variable and assignment. the fabfile parses this
-#: file to get the version for deployment from it.
-VERSION = '2.2'
-
-
-data_files = []
-documentation_path = 'docs/_build/html'
-if os.path.exists(documentation_path):
- documentation_files = []
- for fn in os.listdir(documentation_path):
- if not fn.startswith('.'):
- fn = os.path.join(documentation_path, fn)
- if os.path.isfile(fn):
- documentation_files.append(fn)
- data_files.append(('docs', documentation_files))
-
-
-def get_terminal_width():
- """Return the current terminal dimensions."""
- try:
- from struct import pack, unpack
- from fcntl import ioctl
- from termios import TIOCGWINSZ
- s = pack('HHHH', 0, 0, 0, 0)
- return unpack('HHHH', ioctl(sys.stdout.fileno(), TIOCGWINSZ, s))[1]
- except:
- return 80
-
-
setup(
name='Jinja2',
- version=VERSION,
+ version='2.2',
url='http://jinja.pocoo.org/',
license='BSD',
author='Armin Ronacher',
@@ -86,8 +57,7 @@ setup(
description='A small but fast and easy to use stand-alone template '
'engine written in pure python.',
long_description=__doc__,
- # jinja is egg safe. But because we distribute the documentation
- # in form of html and txt files it's a better idea to extract the files
+ # jinja is egg safe. But we hate eggs
zip_safe=False,
classifiers=[
'Development Status :: 5 - Production/Stable',