summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49cf862..85e32d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,6 +285,20 @@ AC_CHECK_FUNC(clock_gettime,
])
)
+AC_CHECK_FUNC(clock_nanosleep,
+ [
+ AC_DEFINE(HAVE_CLOCK_NANOSLEEP,0,"Whether or not clock_nanosleep can be found in system libraries")
+ ],
+ #
+ # if not found, check librt specifically
+ #
+ AC_CHECK_LIB(rt, clock_nanosleep,
+ [
+ AC_DEFINE(HAVE_CLOCK_NANOSLEEP,1,"Whether or not clock_nanosleep can be found in system libraries")
+ OS_LDFLAGS="$OS_LDFLAGS -lrt"
+ ])
+)
+
# should we use mlockall() on this platform?
if test "x$JACK_DO_NOT_MLOCK" = "x"; then
AC_CHECK_HEADER(sys/mman.h,