summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2011-09-18 00:21:12 +0000
committer <>2014-04-01 14:15:08 +0000
commit5d498a6d7449d44a9278909dd10530ef0a19de29 (patch)
tree416685c8d22c7b5f32e994c9c4d6f1dbc5286c76 /test/Makefile.am
downloaditzam-tarball-420f1c1a7e75ca11d2df65bdf27bea848f508154.tar.gz
Imported from /home/lorry/working-area/delta_itzam-tarball/libitzam-6.0.4.tar.gz.HEADlibitzam-6.0.4master
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..bfb4edb
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,14 @@
+CFLAGS = @CFLAGS@ -std=gnu99
+
+h_sources = itzam_errors.h
+
+bin_PROGRAMS = itzam_btree_test_insert itzam_btree_test_stress itzam_btree_test_threads itzam_btree_test_strvar
+
+itzam_btree_test_insert_SOURCES = itzam_btree_test_insert.c
+itzam_btree_test_stress_SOURCES = itzam_btree_test_stress.c
+itzam_btree_test_threads_SOURCES = itzam_btree_test_threads.c
+itzam_btree_test_strvar_SOURCES = itzam_btree_test_strvar.c
+
+LIBS = -L../src -litzam -lpthread
+
+EXTRA_DIST = itzam_errors.h