summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index dcca3894..eb083d49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,21 +252,10 @@ fi
DISTCHECK_ATF_CONFIGURE_FLAG=
atf_path="no"
AC_ARG_WITH([atf],
- AS_HELP_STRING([--with-atf=PATH],[specify location where atf was installed (or "bind")]),
+ AS_HELP_STRING([--with-atf=PATH],[specify location where atf was installed]),
[atf_path="$withval"])
-AM_CONDITIONAL(BIND_ATF, test "$atf_path" = "bind")
-if test "$atf_path" = "bind" ; then
- DISTCHECK_ATF_CONFIGURE_FLAG="--with-atf=bind"
- atf_pcp="bind"
- atf_path="\${top_srcdir}/bind/atf"
- ATF_CFLAGS="-I$atf_path/include -DUNIT_TEST"
- ATF_LDFLAGS="-L$atf_path/lib -latf-c"
- ATF_BIN=`cd $srcdir; pwd`/bind/atf/bin
- AC_SUBST(ATF_CFLAGS)
- AC_SUBST(ATF_LDFLAGS)
- AC_SUBST(ATF_BIN)
- BINDCONFIG="$BINDCONFIG --with-atf"
-elif test "$atf_path" != "no" ; then
+
+if test "$atf_path" != "no" ; then
DISTCHECK_ATF_CONFIGURE_FLAG="--with-atf=$atf_path"
# Config path for pkg-config
atf_pcp=""