summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShawn Routhier <sar@isc.org>2009-01-22 00:43:58 +0000
committerShawn Routhier <sar@isc.org>2009-01-22 00:43:58 +0000
commitae566556280cc57824f6ab44fdf5aef97274ee42 (patch)
tree671dd88802210218a493303b8949512939db4dba /configure.ac
parent5536fc37e3a0cb0cccce4209f3e06b56885c43d7 (diff)
downloadisc-dhcp-ae566556280cc57824f6ab44fdf5aef97274ee42.tar.gz
Update for 19054 - modifications to keep GCC 4.3 happy
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f16ee875..522129d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,13 @@ if test "$GCC" = "yes"; then
fi
fi
+# POSIX doesn't include the IPv6 Advanced Socket API and glibc hides
+# parts of the IPv6 Advanced Socket API as a result. This is stupid
+# as it breaks how the two halves (Basic and Advanced) of the IPv6
+# Socket API were designed to be used but we have to live with it.
+# Use this to define _GNU_SOURCE to pull in the IPv6 Advanced Socket API.
+AC_USE_SYSTEM_EXTENSIONS
+
AC_PROG_RANLIB
AC_CONFIG_HEADERS([includes/config.h])