summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f71372..00335d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,8 @@ IANA_PEN = http://www.iana.org/assignments/enterprise-numbers
dist-hook:
cp control/ipmitool.spec $(distdir)
-.PHONY: install-pen-database
+.PHONY: install-pen-database uninstall-pen-database
+.INTERMEDIATE: %.o %.la enterprise-numbers
if DOWNLOAD
@@ -63,19 +64,26 @@ install-pen-database: enterprise-numbers
mkdir -m 755 -p $(DESTDIR)$(IANADIR)
$(INSTALL_DATA) $< -t $(DESTDIR)$(IANADIR)/
+uninstall-pen-database:
+ -rm -rf $(DESTDIR)$(IANADIR)/enterprise-numbers
+
else
install-pen-database:
@echo "*** NOT installing the IANA PEN database."
@echo "*** Don't know how to download it."
+uninstall-pen-database:
+ @echo "*** NOT uninstalling the IANA PEN database."
+ @echo "*** It was installed manually (if ever)."
+
endif
install-data-local: install-pen-database
mkdir -p $(DESTDIR)$(DOCDIR)
$(INSTALL_DATA) $(DOCLIST) $(DESTDIR)$(DOCDIR)
-uninstall-local:
+uninstall-local: uninstall-pen-database
-rm -rf $(DESTDIR)$(DOCDIR)
.PHONY: pkg