summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am57
1 files changed, 3 insertions, 54 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9a74820..45cc01c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,62 +20,11 @@
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
check:
- ARGS="--exit"; \
- if test x$(FORCE_TEST) != x ; then \
- ARGS="$$ARGS --force"; \
- fi; \
- ANTHY_SCHEMA_FILE=org.freedesktop.ibus.engine.anthy.gschema.xml; \
- if test \! -f $(builddir)/../data/$$ANTHY_SCHEMA_FILE ; then \
- echo "Not found $(builddir)/../data/$$ANTHY_SCHEMA_FILE"; \
- exit -1; \
- fi; \
- SCHEMA_TMPDIR=`mktemp -d`; \
- if test $$? -ne 0 ; then \
- echo "FAILED mktemp"; \
- exit -1; \
- fi; \
- cp $(builddir)/../data/$$ANTHY_SCHEMA_FILE $$SCHEMA_TMPDIR; \
- glib-compile-schemas $$SCHEMA_TMPDIR; \
- if test $$? -ne 0 ; then \
- echo "FAILED glib-compile-schemas $$SCHEMA_TMPDIR"; \
- exit -1; \
- fi; \
- if test \! -f $$SCHEMA_TMPDIR/gschemas.compiled ; then \
- echo "Not found $$SCHEMA_TMPDIR/gschemas.compiled"; \
- exit -1; \
- fi; \
- ls $(builddir)/../gir/Anthy*.typelib > /dev/null; \
- if test $$? -ne 0 ; then \
- echo "Not found $(builddir)/../gir/Anthy*.typelib"; \
- exit -1; \
- fi; \
- ibus-daemon --daemonize --verbose; \
- sleep 1; \
- SUSER=`echo "$$USER" | cut -c 1-7`; \
- ps -ef | grep "$$SUSER" | grep ibus | grep -v grep; \
- export GSETTINGS_SCHEMA_DIR=$$SCHEMA_TMPDIR; \
- export GI_TYPELIB_PATH=$(builddir)/../gir; \
- LD_LIBRARY_PATH=$(builddir)/../gir/.libs; \
- export LD_LIBRARY_PATH=$${LD_LIBRARY_PATH}:$(builddir)/../gir; \
- export GTK_IM_MODULE=ibus; \
- echo "#### Starting Python3 API test $$ARGS"; \
- env IBUS_ANTHY_ENGINE_PATH=$(srcdir)/../engine/python3 \
- IBUS_ANTHY_SETUP_PATH=$(srcdir)/../setup/python3 \
- python3 -u $(srcdir)/anthytest.py $$ARGS; \
- if test $$? -ne 0 ; then \
- exit -1; \
- fi; \
- if test x$(FORCE_TEST) = x ; then \
- rm -r $$HOME/.anthy; \
- fi; \
- echo "#### Starting Python2 API test"; \
- env IBUS_ANTHY_ENGINE_PATH=$(srcdir)/../engine/python2 \
- IBUS_ANTHY_SETUP_PATH=$(srcdir)/../setup/python2 \
- python2 -u $(srcdir)/anthytest.py $$ARGS; \
- rm -rf $$SCHEMA_TMPDIR; \
- ibus exit
+ bash -x test-build.sh --builddir=$(builddir) --srcdir=$(srcdir)
EXTRA_DIST = \
anthycases.py \
anthytest.py \
+ test-build.sh \
+ test-console.sh \
$(NULL)