summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHuang Peng <shawn.p.huang@gmail.com>2008-08-09 08:20:13 +0800
committerHuang Peng <shawn.p.huang@gmail.com>2008-08-09 08:20:13 +0800
commit391eccdb5281b674d15317967c14a9dc895de3b6 (patch)
tree0abc92c5c5a46eb06b28205c728680f48c9fb369 /configure.ac
parent0b3b87399a492492a5708ebac23182600fc26f94 (diff)
downloadibus-anthy-391eccdb5281b674d15317967c14a9dc895de3b6.tar.gz
Add python-config.py.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36cfcb8..1fc037c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,8 +67,12 @@ AC_SUBST(ENV)
# check python
AM_PATH_PYTHON([2.5])
-PYTHON_CONFIG=`type -p python$PYTHON_VERSION-config`
-if test "$PYTHON_CONFIG" != ""; then
+
+AC_PATH_PROG(PYTHON_CONFIG, python$PYTHON_VERSION-config)
+if test x"$PYTHON_CONFIG" == x""; then
+AC_PATH_PROG(PYTHON_CONFIG, python-config)
+fi
+if test x"$PYTHON_CONFIG" != x""; then
PYTHON_CFLAGS=`$PYTHON_CONFIG --includes`
PYTHON_LIBS=`$PYTHON_CONFIG --libs`
else