summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2009-06-17 15:57:32 +0800
committerPeng Huang <shawn.p.huang@gmail.com>2009-06-17 15:57:32 +0800
commit1ab43e76bfbad4f96c8a506f41c72efcf5c44b8f (patch)
treef08f06e03b2db635284f0fcd9ab45f871ad79f6b /configure.ac
parent8acfe8de97a0099aab0b3724c3a95fd409aba6be (diff)
downloadibus-anthy-1ab43e76bfbad4f96c8a506f41c72efcf5c44b8f.tar.gz
Fix problems when 'make rpm'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1ff3f7..b9c474d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,13 @@ AC_ISC_POSIX
AC_HEADER_STDC
AM_PROG_LIBTOOL
+# For dislpay Date
+m4_define(ibus_maybe_datedisplay,
+ m4_esyscmd([if test x]ibus_released[ != x1; then date '+%a %b %d %Y' | tr -d '\n\r'; fi]))
+m4_define([ibus_datedisplay], ibus_maybe_datedisplay)
+DATE_DISPLAY="ibus_datedisplay"
+AC_SUBST(DATE_DISPLAY)
+
# check anthy
PKG_CHECK_MODULES(ANTHY, [
anthy