summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBrendan O'Dea <bod@debian.org>2009-11-14 17:45:49 +1100
committerBrendan O'Dea <bod@debian.org>2009-11-14 17:45:49 +1100
commit00803360fdd9853123747fd2c7e30d5fab20b2f0 (patch)
tree07f4b0ca7594446d1e7d11d51a313695b89dd173 /configure.in
parent9ec2e29043f013bc7af84847acca78015fd100a3 (diff)
downloadhelp2man-00803360fdd9853123747fd2c7e30d5fab20b2f0.tar.gz
revise preload mechanism to not require preloadable libintl
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 3be80ed..e2553ea 100644
--- a/configure.in
+++ b/configure.in
@@ -9,15 +9,13 @@ AC_PATH_PROG(MSGFMT, msgfmt)
AC_PROG_CC
AC_SEARCH_LIBS(dlsym, dl)
-
-AC_MSG_CHECKING([for pre-loadable libintl])
-preload=`LD_PRELOAD="preloadable_libintl.so" sh -c 'echo yes' 2>/dev/null`
-AC_MSG_RESULT(${preload:=no})
+AC_SEARCH_LIBS(bindtextdomain, intl)
nls_default=yes
-test "$ac_cv_module_Locale__gettext" = no && nls_default=no
+test "x$ac_cv_module_Locale__gettext" = xno && nls_default=no
test -z "$MSGFMT" && nls_default=no
-test "$preload" = no && nls_default=no
+test "x$ac_cv_search_dlsym" = xno && nls_default=no
+test "x$ac_cv_search_bindtextdomain" = xno && nls_default=no
AC_ARG_ENABLE([nls], AC_HELP_STRING([--enable-nls],
[enable support for generating localised pages]),
@@ -29,13 +27,16 @@ AC_SUBST(extra_extract_args, '')
if test "$ac_cv_enable_nls" = yes
then
# note: the following tests should match what is used to set nls_default above
- test "$ac_cv_module_Locale__gettext" = no &&
+ test "x$ac_cv_module_Locale__gettext" = xno &&
AC_MSG_ERROR([perl module Locale::gettext required])
test -z "$MSGFMT" && AC_MSG_ERROR([gettext required])
- test "$preload" = no &&
- AC_MSG_ERROR([libpreloadable_libintl.so required (gettext 0.12+)])
+ test "x$ac_cv_search_dlsym" = xno &&
+ AC_MSG_ERROR([dlsym() required])
+
+ test "x$ac_cv_search_bindtextdomain" = xno &&
+ AC_MSG_ERROR([bindtextdomain() required])
extra_make_all='preload man_l10n'
extra_make_install='install_preload install_l10n'