summaryrefslogtreecommitdiff
path: root/ghc/runtime/regex/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'ghc/runtime/regex/configure.in')
-rw-r--r--ghc/runtime/regex/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/ghc/runtime/regex/configure.in b/ghc/runtime/regex/configure.in
new file mode 100644
index 0000000000..f0fc780250
--- /dev/null
+++ b/ghc/runtime/regex/configure.in
@@ -0,0 +1,23 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(regex.c)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl I'm not sure if AC_AIX and AC_DYNIX_SEQ are really necessary. The
+dnl Autoconf documentation isn't specific about which BSD functions they
+dnl provide.
+AC_AIX
+AC_DYNIX_SEQ
+AC_ISC_POSIX
+AC_MINIX
+
+AC_STDC_HEADERS
+AC_HAVE_HEADERS(string.h)
+
+AC_ALLOCA
+AC_CONST
+
+AC_PREFIX(gcc)
+
+AC_OUTPUT(Makefile doc/Makefile test/Makefile)