summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b5855f4ef0..2e683cdef3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,7 +333,7 @@ AC_SUBST(TablesNextToCode)
dnl ** Does target have runtime linker support?
dnl --------------------------------------------------------------
case "$target" in
- powerpc64-*|powerpc64le-*|powerpc-ibm-aix*|s390x-ibm-linux|riscv64-*|wasm*)
+ powerpc64-*|powerpc64le-*|powerpc-ibm-aix*|s390x-ibm-linux|riscv64-*|wasm*|js-*)
TargetHasRTSLinker=NO
;;
*)
@@ -691,8 +691,12 @@ AC_SUBST(CONF_HC_OPTS_STAGE0)
AC_SUBST(CONF_HC_OPTS_STAGE1)
AC_SUBST(CONF_HC_OPTS_STAGE2)
-dnl Identify C++ standard library flavour and location
-FP_FIND_CXX_STD_LIB
+dnl Identify C++ standard library flavour and location only when _not_ compiling
+dnl the JS backend. The JS backend uses emscripten to wrap c++ utilities which
+dnl fails this check, so we avoid it when compiling to JS.
+if test "$TargetOS" != "ghcjs"; then
+ FP_FIND_CXX_STD_LIB
+fi
AC_CONFIG_FILES([mk/system-cxx-std-lib-1.0.conf])
dnl ** Set up the variables for the platform in the settings file.