summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Trommler <ptrommler@acm.org>2018-12-30 22:23:53 +0100
committerBen Gamari <ben@smart-cactus.org>2019-01-01 11:44:16 -0500
commit374e44704b64afafc1179127e6c9c5bf1715ef39 (patch)
treee55962e8ac605a6762a18e30c8614d772effb2eb /configure.ac
parentae4f1033cfe131fca9416e2993bda081e1f8c152 (diff)
downloadhaskell-374e44704b64afafc1179127e6c9c5bf1715ef39.tar.gz
PPC NCG: Remove Darwin support
Support for Mac OS X on PowerPC has been dropped by Apple years ago. We follow suit and remove PowerPC support for Darwin. Fixes #16106.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 021ef94845..874a128bdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1221,16 +1221,7 @@ case ${TargetOS} in
RtsLinkerUseMmap=1
;;
darwin|ios|watchos|tvos)
- # Don't use mmap on powerpc/darwin as the mmap there doesn't support
- # reallocating. Reallocating is needed to allocate jump islands just
- # after each object image. Jumps to these jump islands use relative
- # branches which are limited to offsets that can be represented in
- # 24-bits.
- if test "$TargetArch" != "powerpc" ; then
- RtsLinkerUseMmap=1
- else
- RtsLinkerUseMmap=0
- fi
+ RtsLinkerUseMmap=1
;;
*)
# Windows (which doesn't have mmap) and everything else.