summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCheng Shao <astrohavoc@gmail.com>2022-10-21 13:56:52 +0000
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-11-11 00:26:54 -0500
commit2829fd9257abc1b78ebd27692de96fb74c6afcfa (patch)
treea6d19ebebcc52b768085e608221e97f5f0df5d0a /configure.ac
parent1230c2689db2e510b5a9b280c1a4eca832c23ccc (diff)
downloadhaskell-2829fd9257abc1b78ebd27692de96fb74c6afcfa.tar.gz
autoconf: check getpid getuid raise
This patch adds checks for getpid, getuid and raise in autoconf. These functions are absent in wasm32-wasi and thus needs to be checked.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a96a15ffbe..1a39d71533 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1022,6 +1022,8 @@ dnl ** check for eventfd which is needed by the I/O manager
AC_CHECK_HEADERS([sys/eventfd.h])
AC_CHECK_FUNCS([eventfd])
+AC_CHECK_FUNCS([getpid getuid raise])
+
dnl ** Check for __thread support in the compiler
AC_MSG_CHECKING(for __thread support)
AC_COMPILE_IFELSE(