summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2012-03-15 14:56:37 +0000
committerIan Lynagh <igloo@earth.li>2012-03-15 15:57:12 +0000
commit634ffaff45896dad3cc08ac38611861fb46eb3d6 (patch)
treeb4b254f0616f0d99a33db19daf3836626e64d173 /configure.ac
parent4bbe9f719f4c26e7f2d8e5a3a8096ac956e1be6c (diff)
downloadhaskell-634ffaff45896dad3cc08ac38611861fb46eb3d6.tar.gz
Some configure/aclocal fixes for Win64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4951467b4d..c25fbe5aa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,9 +159,9 @@ fi;
# GHC is passed to Cabal, so we need a native path
if test "${WithGhc}" != ""
then
- ghc_host=`"${WithGhc}" +RTS --info | grep 'Host platform' | sed -e 's/.*, "//' -e 's/")//'`
+ ghc_host_os=`"${WithGhc}" +RTS --info | grep 'Host OS' | sed -e 's/.*, "//' -e 's/")//'`
- if test "$ghc_host" = "i386-unknown-mingw32"
+ if test "$ghc_host_os" = "mingw32"
then
if test "${OSTYPE}" = "msys"
then
@@ -447,10 +447,11 @@ dnl --------------------------------------------------------------
dnl ** Can the unix package be built?
dnl --------------------------------------------------------------
-if test x"$TargetPlatform" = x"i386-unknown-mingw32"; then
- GhcLibsWithUnix=NO
+if test "$TargetOS" = "mingw32"
+then
+ GhcLibsWithUnix=NO
else
- GhcLibsWithUnix=YES
+ GhcLibsWithUnix=YES
fi
AC_SUBST([GhcLibsWithUnix])
@@ -571,9 +572,9 @@ AC_SUBST(HaveDtrace)
AC_PATH_PROG(HSCOLOUR,HsColour)
# HsColour is passed to Cabal, so we need a native path
-if test "x$HostPlatform" = "xi386-unknown-mingw32" && \
- test "${OSTYPE}" != "msys" && \
- test "${HSCOLOUR}" != ""
+if test "$HostOS" = "mingw32" && \
+ test "${OSTYPE}" != "msys" && \
+ test "${HSCOLOUR}" != ""
then
# Canonicalise to <drive>:/path/to/gcc
HSCOLOUR=`cygpath -m ${HSCOLOUR}`