summaryrefslogtreecommitdiff
path: root/tests
Commit message (Collapse)AuthorAgeFilesLines
* make testdnd trashcan work againCaolán McNamara2021-06-231-1/+1
| | | | so that dragging into the 'trashcan' is detected
* testgaction: Add more widgetryMatthias Clasen2021-06-101-0/+45
| | | | | Add some toggle and check buttons to test that they work as expected as GtkActionables.
* Fix the GAction testMatthias Clasen2021-06-101-3/+9
| | | | We weren't setting the state of the stateful actions.
* tests: Fix check vs toggle button confusionMatthias Clasen2021-06-101-6/+6
| | | | Check buttons aren't toggle buttons anymore.
* GtkFileFilter: Add suffix matchesMatthias Clasen2021-06-041-2/+2
| | | | | | | | This is less flexible than a glob pattern, but it is explicitly case-insensitive, to match the behavior on Windows. Fixes: #3705
* Move text history testsMatthias Clasen2021-05-262-601/+0
| | | | | | We can test internal apis in our testsuite now, so move the text history tests there, to have them run in ci.
* testzoom: Fix the in-place rotateMatthias Clasen2021-05-131-10/+35
|
* Add a transform testMatthias Clasen2021-05-122-0/+277
| | | | This reveals some issues with scale handling.
* test: Ensure .image-button on header bar buttonsAlexander Mikhaylenko2021-05-091-4/+1
|
* test: Use more appropriate back/forward iconsAlexander Mikhaylenko2021-05-092-3/+3
|
* Remove assertions in testsMatthias Clasen2021-04-121-10/+10
|
* Add a test for popover positioningMatthias Clasen2021-02-142-0/+132
| | | | | This is useful for testing the interaction of arrows, shadows or offsets with popover positioning.
* showrendernode: Monitor input fileTimm Bäder2021-01-291-37/+76
|
* Drop unused logo resourceMatthias Clasen2021-01-281-1/+1
| | | | The inspector no longer sets a window icon.
* gl: Fix implicit leaking of shader objectxndcn2020-12-291-0/+2
| | | | | | | | | | According to OpenGL spec, a shader object will only be flagged for deletion unless it has been detached; when a program object is deleted, those shader objects attached to it will be detached but not deleted unless they have already been flagged for deletion. So we shall detach a shader object before it is deleted, and delete it before the program object is deleted best.
* build: Use a consistent style for Meson filesEmmanuele Bassi2020-12-151-6/+10
|
* gdk: Replace 'WITHDRAWN' state with async 'is-mapped' booleanJonas Ådahl2020-12-071-2/+0
| | | | | | | | | | | | | | | | | | | It was used by all surfaces to track 'is-mapped', but still part of the GdkToplevelState, and is now replaced with a separate boolean in the GdkSurface structure. It also caused issues when a widget was unmapped, and due to that unmapped a popover which hid its corresponding surface. When this surface was hidden, it emitted a state change event, which would then go back into GTK and queue a resize on popover widget, which would travel back down to the widget that was originally unmapped, causing confusino when doing future allocations. To summarize, one should not hide widgets during allocation, and to avoid this, make this new is-mapped boolean asynchronous when hiding a surface, meaning the notification event for the changed mapped state will be emitted in an idle callback. This avoids the above described reentry issue.
* tests/animated-resizing: Use gtk_window_default_size() insteadJonas Ådahl2020-12-071-1/+1
| | | | | This will actually make it resize on-demand, as the default size is the size used when computing the window size when the size is not fixed.
* tests/animated-resizing: Don't try to resize during frame dispatchJonas Ådahl2020-12-071-4/+12
| | | | | | This will not work on X11 because it's too late to resize, due to resizing being asynchronous i.e. it won't be complete before we need to draw.
* gdk: Remove GdkSurface::size-changedJonas Ådahl2020-12-071-5/+18
| | | | | It's not emitted, and everyone should use the GdkSurface::layout signal from now on.
* tests/testgtk: Remove 'Resize' buttonJonas Ådahl2020-12-071-18/+0
| | | | The gtk_window_resize() API is going away, so remove this test.
* tests/animated-resizing: Resize widget instead of windowJonas Ådahl2020-12-071-2/+3
| | | | | This means the window needs to be marked as non-resizable, otherwise it won't shrink.
* tests: Use gtk_window_set_default_size() when appropriateJonas Ådahl2020-12-072-4/+4
| | | | | Replace the usage of gtk_window_resize() with gtk_window_set_default_size() where possible.
* gtk: Remove GtkFileChooserButtonBenjamin Otte2020-12-032-284/+0
| | | | ... as discussed in the meeting.
* tests: Remove testsvgBenjamin Otte2020-12-022-252/+0
| | | | That demo lives in gtk-demo now.
* Merge branch 'wip/otte/for-master' into 'master'Benjamin Otte2020-11-171-2/+0
|\ | | | | | | | | Wip/otte/for master See merge request GNOME/gtk!2855
| * tests: Fix for new tranfer behavior of constructorsBenjamin Otte2020-11-171-2/+0
| | | | | | | | | | We were still unreffing a listmodel where the reference wasn't ours anymore.
* | Remove pointless inout argumentsebassi/inout-argsEmmanuele Bassi2020-11-171-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | GtkTreeView.get_tooltip_context() takes an inout X and Y coordinates, but the "out" side is a side effect: the conversion from widget-relative to bin window-relative coordinates is not documented, and can be done using public API, if needed. GtkIconView.get_tooltip_context() follows the same pattern, and takes two inout arguments for the coordinates, but it does not change them any more, after GtkIconView's bin window was dropped in commit 8dc5e13e. There's really no point in having these `inout` arguments, and while GtkTreeView and GtkIconView are certainly de-emphasised in GTK4, and we nudge developers to move to the new list views, we should take advantage of the API break to remove warts.
* | gsk: Avoid using gtk css types in public apigsk-binding-apiMatthias Clasen2020-11-162-12/+34
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Using GtkCssSection in public headers here may be ok from the C perspective, since it all ends up in the same library anyway. But it causes circular dependency problems for our gir files that are still split by namespace. To avoid this problem, copy the GtkCssLocation struct struct as GskParseLocation, and pass take two of them instead of a GtkCssSection in the error callback. Update all users. Fixes: #2454
* | Fix tests with regard to GtkBuilder <requires>.arnaudb/requiresArnaud Bonatti2020-11-071-7/+7
|/
* showrendernode: Pass error to deserialize()Timm Bäder2020-10-221-1/+1
|
* showrendernode: Plug GOptionContext memory leakTimm Bäder2020-10-141-0/+3
|
* testfilechooser: Stop listening to ::selection-changedTimm Bäder2020-10-141-22/+0
| | | | Doesn't exist anymore.
* testupload: Test more formatsMatthias Clasen2020-09-261-219/+341
| | | | | | | | | | Copy the format conversion code from GdkMemoryTexture so we can produce all formats, and test them all. The upload fast paths assume that the stride is a multiple of four, so some of the padding values cause it to fail. Apart from that, things seem to work for all combinations.
* Add a test for various texture uploadsMatthias Clasen2020-09-262-0/+278
| | | | | | | | | | | Create textures with various characteristics (alpha, premultiplication, stride) that trigger different code paths in the gl texture upload function, and show the resulting images. If all goes well, they all should look the same. On my system, this tests texture upload for memory formats GDK_MEMORY_B8G8R8A8_PREMULTIPLIED, GDK_MEMORY_R8G8B8A8, and GDK_MEMORY_R8G8B8, and it works with both gl and gles.
* Merge branch 'matthiasc/for-master' into 'master'Matthias Clasen2020-09-252-2/+2
|\ | | | | | | | | columnview: Simplify column constructors See merge request GNOME/gtk!2622
| * columnview: Simplify column constructorsMatthias Clasen2020-09-252-2/+2
| | | | | | | | | | | | | | | | | | Drop gtk_column_view_column_new_with_factory and just make gtk_column_view_column_new accept a nullable factory. This follows what we've been doing elsewhere. Update all callers.
* | gtkscrolledwindow: Drop gtk_scrolled_window_set_capture_button_press()Carlos Garnacho2020-09-251-3/+0
|/ | | | | | This API is kinda stuck in the GdkEvent days, we now negotiate ownership of the input sequence via GtkGestures. Remove it as it reflects a way to work that was not exactly accurate and it will turn plainly wrong soon.
* Clean up lots of GTK+ -> GTKMatthias Clasen2020-09-122-2/+2
| | | | | | Replace most remaining uses of GTK+ in the docs and user-visible strings by GTK. Also remove some leftover "Was added in 3.x" sentences from the docs.
* Add a testcase for controls in headerbarsMatthias Clasen2020-09-122-0/+75
| | | | | This is meant to help with figuring out entry selection drag issues.
* gdk: Rename GdkSurfaceState to GdkToplevelStateMatthias Clasen2020-09-101-8/+8
| | | | | | That is what it is. Fixes: #2790
* Merge branch 'filter-constructors' into 'master'Matthias Clasen2020-09-083-6/+6
|\ | | | | | | | | Filter constructors See merge request GNOME/gtk!2360
| * Make sorter constructors return exact typesfilter-constructorsMatthias Clasen2020-09-053-4/+4
| | | | | | | | | | | | | | Make functions like gtk_custom_sorter_new() return the actual type they construct. Update all callers.
| * Make filter constructors return exact typesMatthias Clasen2020-09-052-2/+2
| | | | | | | | | | | | | | Make functions like gtk_custom_filter_new() return the actual type they construct. Update all callers.
* | Beef up transform testcaseMatthias Clasen2020-09-041-5/+21
|/ | | | Make this show 'paintings in paintings'.
* Add a simple testcase for transformsMatthias Clasen2020-09-032-0/+78
| | | | | This can help in tracking various things down, from picking to clipping.
* list widgets: Simplify the constructorsMatthias Clasen2020-09-014-6/+6
| | | | | | | Now that both arguments to the _new_with_factory() constructors are nullable, there's no good reason to keep a separate _new() around. Just make gtk_list_view_new() and gtk_grid_view_new() take both a model and a factory.
* list widgets: Use selection models in the apiMatthias Clasen2020-08-314-8/+14
| | | | | | | | Change the apis in GtkListView, GtkColumnView and GtkGridView to be explicitly about GtkSelectionModel, to make it obvious that the widgets handle selection. Update all users.
* Remove GtkRadioButton references in the docsMatthias Clasen2020-08-301-4/+0
|
* Clean up uses of gtk_toggle_button_get/set_activeMatthias Clasen2020-08-3010-44/+44
| | | | | Replace all uses on check buttons by the corresponding check button api.