summaryrefslogtreecommitdiff
path: root/tests/testgtk.c
Commit message (Collapse)AuthorAgeFilesLines
* tests: Stop using gtk_widget_show/hideMatthias Clasen2022-12-131-36/+33
|
* tests: Ignore deprecationsMatthias Clasen2022-10-111-0/+2
| | | | Eventually, most of these tests should be dropped.
* testgtk: Use global css providerBenjamin Otte2022-10-091-11/+15
|
* Deprecate GtkEntryCompletionMatthias Clasen2022-10-031-0/+6
| | | | | | We want to drop cell renderers and tree models in GTK 5. The functionality of GtkEntryCompletion may be replaced by a new widget in GTK 5.
* GtkFileFilter: Add suffix matchesMatthias Clasen2021-06-041-2/+2
| | | | | | | | This is less flexible than a glob pattern, but it is explicitly case-insensitive, to match the behavior on Windows. Fixes: #3705
* gdk: Replace 'WITHDRAWN' state with async 'is-mapped' booleanJonas Ådahl2020-12-071-2/+0
| | | | | | | | | | | | | | | | | | | It was used by all surfaces to track 'is-mapped', but still part of the GdkToplevelState, and is now replaced with a separate boolean in the GdkSurface structure. It also caused issues when a widget was unmapped, and due to that unmapped a popover which hid its corresponding surface. When this surface was hidden, it emitted a state change event, which would then go back into GTK and queue a resize on popover widget, which would travel back down to the widget that was originally unmapped, causing confusino when doing future allocations. To summarize, one should not hide widgets during allocation, and to avoid this, make this new is-mapped boolean asynchronous when hiding a surface, meaning the notification event for the changed mapped state will be emitted in an idle callback. This avoids the above described reentry issue.
* tests/testgtk: Remove 'Resize' buttonJonas Ådahl2020-12-071-18/+0
| | | | The gtk_window_resize() API is going away, so remove this test.
* gdk: Rename GdkSurfaceState to GdkToplevelStateMatthias Clasen2020-09-101-8/+8
| | | | | | That is what it is. Fixes: #2790
* Remove GtkRadioButton references in the docsMatthias Clasen2020-08-301-4/+0
|
* tests: Stop using radio buttonsMatthias Clasen2020-08-301-29/+31
| | | | Use grouped check buttons.
* Drop GtkAccelLabelMatthias Clasen2020-08-041-100/+0
| | | | We no longer use this widget anywhere.
* testgtk: More GTimeVal eradicationMatthias Clasen2020-07-311-11/+9
|
* Replace "gdouble" with "double"Benjamin Otte2020-07-251-11/+11
|
* Replace "gchar" with "char"Benjamin Otte2020-07-251-30/+30
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-41/+41
|
* filechooser: Make get_files return a list modelMatthias Clasen2020-07-091-5/+9
| | | | | | Like the other list getters in this interface, make gtk_file_chooser_get_files() return a list model.
* filechooser: Add gtk_file_chooser_get_filtersMatthias Clasen2020-07-061-5/+9
| | | | | | | Replace gtk_file_chooser_list_filters with a new api that returns a list model. Update all callers.
* filefiler: No more floatingMatthias Clasen2020-07-051-0/+5
| | | | | | Make GtkFileFilter not be initially unowned anymore. This is in preparation for deriving GtkFileFilter from GtkFilter. Update all callers.
* Stop setting GTK_IM_MODULE_FILEMatthias Clasen2020-06-281-10/+1
| | | | | | GTK no longer reads this environment variable, so setting it can have no benefit for uninstalled demos anymore.
* Merge branch 'scrolled-window-api' into 'master'Matthias Clasen2020-06-241-3/+3
|\ | | | | | | | | scrolledwindow: Don't take adjustments in new() See merge request GNOME/gtk!2146
| * scrolledwindow: Don't take adjustments in new()Matthias Clasen2020-06-241-3/+3
| | | | | | | | | | | | | | In 99.9% of all cases, these are just NULL, NULL. So just do away with these arguments, people can use the setters for the rare cases where they want the scrolled window to use a different adjustment.
* | testgtk: Update list of cursor namesMatthias Clasen2020-06-241-97/+36
|/ | | | | Use the standard names, since that is what we want everybody else to use too.
* Fix minor typosYuri Chornoivan2020-05-281-1/+1
|
* testgtk: Add G_GNUC_NORETURN to usage()Timm Bäder2020-05-191-1/+1
|
* Replace most remaining uses of container apiMatthias Clasen2020-05-111-353/+340
| | | | These are all on GtkBox or enumerating children.
* Stop using container api on GtkNotebookMatthias Clasen2020-05-111-3/+5
|
* Don't use container api on GtkListBoxMatthias Clasen2020-05-111-1/+1
|
* paned: Redo the apiMatthias Clasen2020-05-111-45/+87
| | | | | | | | | | | | This commit is porting GtkPaned to be derived from GtkWidget instead of GtkContainer, while adding start-child and end-child properties. The existing properties are renamed to follow the start/end naming scheme, and we add proper getters and setters. Update all users. See #2719
* Use gtk_expander_set_child throughoutMatthias Clasen2020-05-111-1/+1
| | | | | Replace all uses of gtk_container_add on expanders with gtk_expander_set_child.
* Use gtk_window_destroyMatthias Clasen2020-05-111-79/+79
| | | | | Replace calls to gtk_widget_destroy on windows with gtk_window_destroy.
* Stop using gtk_widget_destroyedMatthias Clasen2020-05-111-159/+63
| | | | | Replace all internal use of gtk_widget_destroyed by g_object_add_weak_pointer.
* tests: Stop explicitly showing widgetsAlexander Mikhaylenko2020-05-111-46/+0
|
* tests: Fix testgtkAlexander Mikhaylenko2020-05-111-62/+138
| | | | An assorted collection of fixes.
* tests: Stop using ::size-allocateMatthias Clasen2020-05-061-19/+0
|
* testgtk: Fix g_object_new useMatthias Clasen2020-05-041-1/+1
| | | | This is the kind of thing that happens with varargs apis.
* Use gtk_window_set_child throughoutMatthias Clasen2020-05-041-27/+27
| | | | | Replace all uses of gtk_container_add on windows by gtk_window_set_child.
* Use gtk_button_set_child throughoutMatthias Clasen2020-05-041-11/+10
| | | | | Replace all uses of gtk_container_add on buttons by gtk_button_set_child.
* Use gtk_scrolled_window_set_child throughoutMatthias Clasen2020-05-041-6/+6
| | | | | Replace all uses of gtk_container_add on popovers by gtk_scrolled_window_set_child.
* Use gtk_frame_set_child throughoutMatthias Clasen2020-05-041-35/+35
| | | | | Replace all uses of gtk_container_add for frames with gtk_frame_set_child.
* tests: Stop using focus adjustmentsMatthias Clasen2020-04-181-4/+2
| | | | Set scroll-to-focus instead, in testgtk.
* frame: Drop shadow-typeMatthias Clasen2020-04-171-13/+0
| | | | | Frames that don't draw frames are not very useful, so just drop the shadow-type property.
* label: Remove public pattern APITimm Bäder2020-04-171-1/+0
|
* tests: Stop using gtk_accelerator_set_default_mod_maskMatthias Clasen2020-04-061-7/+0
| | | | This is not doing anything useful here.
* Turn GtkShortcutAction into a GObjectEmmanuele Bassi2020-03-251-1/+1
| | | | | | Just like we did for GtkShortcutTrigger. This allows language bindings to properly deal with all the actions.
* testgtk: Port keyval example to shortcut controllersEmmanuele Bassi2020-03-251-17/+20
|
* accelerators: Make gtk_accelerator_parse() return TRUE/FALSEBenjamin Otte2020-03-251-2/+4
| | | | A parse function should return success or not. So do that.
* gtk: Remove bindingsBenjamin Otte2020-03-251-10/+0
| | | | The whole binding functionality is now handled by shortcuts.
* Revert "Merge branch 'disable-window-test' into 'master'"Matthias Clasen2020-03-191-24/+29
| | | | | This reverts commit 3ac4c76b18cc89a841ce09f0943539f16988fd21, reversing changes made to 6ec96d2e989d029a303b8b20ec72b86f974c0e87.
* testgtk: Port keyval example to shortcut controllersEmmanuele Bassi2020-03-181-17/+20
|
* accelerators: Make gtk_accelerator_parse() return TRUE/FALSEBenjamin Otte2020-03-181-2/+4
| | | | A parse function should return success or not. So do that.