summaryrefslogtreecommitdiff
path: root/gtk
Commit message (Collapse)AuthorAgeFilesLines
* Adwaita: Regenerate CSS from SASSDaniel Boles2018-03-222-2/+12
| | | | | | | https://gitlab.gnome.org/GNOME/gtk/merge_requests/66 introduced spurious red/green fore/background. Also, the GtkVideo stuff didn't get regenerated in.
* Merge branch 'toolbar-spacing-fix' into 'master'Daniel Boles2018-03-223-7/+6
|\ | | | | | | | | theme: Be more selective when adding margins to toolbar items See merge request GNOME/gtk!66
| * theme: Be more selective when adding margins to toolbar itemsNikita Churaev2018-03-183-7/+6
| | | | | | | | | | Only add margins to direct children of toolbar items, this fixes the gaps between linked buttons inside custom toolbar items.
* | Continue renaming window to surfaceAlexander Larsson2018-03-2143-829/+829
| | | | | | | | This renames a lot of arguments, local variables and functions.
* | Fix up indentation after GdkSurface renameAlexander Larsson2018-03-211-144/+144
| | | | | | | | | | | | This fixes up a lot of the indentation issues from the rename of windows to surfaces, at least the ones in the headers and many others.
* | surface: Simplify gdk_surface_invalidate_region()Benjamin Otte2018-03-212-2/+2
| | | | | | | | | | | | Remove duplicate functions and unused arguments. Functionality is identical otherwise.
* | gdk: Remove gdk_surface_shape_combine_region()Benjamin Otte2018-03-215-75/+2
| | | | | | | | | | | | | | If you want transparent region, you can just render them transparent. If you want input shaping, use gdk_surface_input_shape_combine_region(). Also remove gtk_widget_shape_combine_region().
* | widget: Remove useless macroBenjamin Otte2018-03-211-4/+2
| |
* | Merge branch 'rename-window-to-surface' into 'master'Alexander Larsson2018-03-20121-1279/+1279
|\ \ | | | | | | | | | | | | Rename window to surface See merge request GNOME/gtk!72
| * | Convert all references to GdkEvent->surfaceAlexander Larsson2018-03-202-3/+3
| | |
| * | GtkWidget: Continuer rename of widget->surfaceAlexander Larsson2018-03-203-112/+112
| | | | | | | | | | | | This completes the rename manually.
| * | GtkWidget: Start renaming widget->windowAlexander Larsson2018-03-2097-332/+332
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is an automated change doing these command: git sed -f g gtk_widget_set_has_window gtk_widget_set_has_surface git sed -f g gtk_widget_get_has_window gtk_widget_get_has_surface git sed -f g gtk_widget_set_parent_window gtk_widget_set_parent_surface git sed -f g gtk_widget_get_parent_window gtk_widget_get_parent_surface git sed -f g gtk_widget_set_window gtk_widget_set_surface git sed -f g gtk_widget_get_window gtk_widget_get_surface git sed -f g gtk_widget_register_window gtk_widget_register_surface git sed -f g gtk_widget_unregister_window gtk_widget_unregister_surface git checkout NEWS*
| * | GdkSurface: Rename lots of stuff from window->surfaceAlexander Larsson2018-03-2012-67/+67
| | | | | | | | | | | | | | | Mostly these are internal things, but the major public change is that event.window is now event.surface.
| * | GdkSurface: Rename various functions and variablesAlexander Larsson2018-03-2018-147/+147
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is an automatic rename of various things related to the window->surface rename. Public symbols changed by this is: GDK_MODE_WINDOW gdk_device_get_window_at_position gdk_device_get_window_at_position_double gdk_device_get_last_event_window gdk_display_get_monitor_at_window gdk_drag_context_get_source_window gdk_drag_context_get_dest_window gdk_drag_context_get_drag_window gdk_draw_context_get_window gdk_drawing_context_get_window gdk_gl_context_get_window gdk_synthesize_window_state gdk_surface_get_window_type gdk_x11_display_set_window_scale gsk_renderer_new_for_window gsk_renderer_get_window gtk_text_view_buffer_to_window_coords gtk_tree_view_convert_widget_to_bin_window_coords gtk_tree_view_convert_tree_to_bin_window_coords The commands that generated this are: git sed -f g "GDK window" "GDK surface" git sed -f g window_impl surface_impl (cd gdk; git sed -f g impl_window impl_surface) git sed -f g WINDOW_IMPL SURFACE_IMPL git sed -f g GDK_MODE_WINDOW GDK_MODE_SURFACE git sed -f g gdk_draw_context_get_window gdk_draw_context_get_surface git sed -f g gdk_drawing_context_get_window gdk_drawing_context_get_surface git sed -f g gdk_gl_context_get_window gdk_gl_context_get_surface git sed -f g gsk_renderer_get_window gsk_renderer_get_surface git sed -f g gsk_renderer_new_for_window gsk_renderer_new_for_surface (cd gdk; git sed -f g window_type surface_type) git sed -f g gdk_surface_get_window_type gdk_surface_get_surface_type git sed -f g window_at_position surface_at_position git sed -f g event_window event_surface git sed -f g window_coord surface_coord git sed -f g window_state surface_state git sed -f g window_cursor surface_cursor git sed -f g window_scale surface_scale git sed -f g window_events surface_events git sed -f g monitor_at_window monitor_at_surface git sed -f g window_under_pointer surface_under_pointer (cd gdk; git sed -f g for_window for_surface) git sed -f g window_anchor surface_anchor git sed -f g WINDOW_IS_TOPLEVEL SURFACE_IS_TOPLEVEL git sed -f g native_window native_surface git sed -f g source_window source_surface git sed -f g dest_window dest_surface git sed -f g drag_window drag_surface git sed -f g input_window input_surface git checkout NEWS* po-properties po docs/reference/gtk/migrating-3to4.xml
| * | GdkWindow -> GdkSurface: File renamesAlexander Larsson2018-03-202-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Rename all *window.[ch] source files. This is an automatic operation, done by the following commands: for i in $(git ls-files gdk | grep window); do git mv $i $(echo $i | sed s/window/surface/); git sed -f g $(basename $i) $(basename $i | sed s/window/surface/) ; done git checkout NEWS* po-properties po
| * | GdkWindow -> GdkSurface initial type renameAlexander Larsson2018-03-2064-822/+822
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This renames the GdkWindow class and related classes (impl, backend subclasses) to surface. Additionally it renames related types: GdkWindowAttr, GdkWindowPaint, GdkWindowWindowClass, GdkWindowType, GdkWindowTypeHint, GdkWindowHints, GdkWindowState, GdkWindowEdge This is an automatic conversion using the below commands: git sed -f g GdkWindowWindowClass GdkSurfaceSurfaceClass git sed -f g GdkWindow GdkSurface git sed -f g "gdk_window\([ _\(\),;]\|$\)" "gdk_surface\1" # Avoid hitting gdk_windowing git sed -f g "GDK_WINDOW\([ _\(]\|$\)" "GDK_SURFACE\1" # Avoid hitting GDK_WINDOWING git sed "GDK_\([A-Z]*\)IS_WINDOW\([_ (]\|$\)" "GDK_\1IS_SURFACE\2" git sed GDK_TYPE_WINDOW GDK_TYPE_SURFACE git sed -f g GdkPointerWindowInfo GdkPointerSurfaceInfo git sed -f g "BROADWAY_WINDOW" "BROADWAY_SURFACE" git sed -f g "broadway_window" "broadway_surface" git sed -f g "BroadwayWindow" "BroadwaySurface" git sed -f g "WAYLAND_WINDOW" "WAYLAND_SURFACE" git sed -f g "wayland_window" "wayland_surface" git sed -f g "WaylandWindow" "WaylandSurface" git sed -f g "X11_WINDOW" "X11_SURFACE" git sed -f g "x11_window" "x11_surface" git sed -f g "X11Window" "X11Surface" git sed -f g "WIN32_WINDOW" "WIN32_SURFACE" git sed -f g "win32_window" "win32_surface" git sed -f g "Win32Window" "Win32Surface" git sed -f g "QUARTZ_WINDOW" "QUARTZ_SURFACE" git sed -f g "quartz_window" "quartz_surface" git sed -f g "QuartzWindow" "QuartzSurface" git checkout NEWS* po-properties
* | | Merge branch 'accessible-role' into 'master'Matthias Clasen2018-03-201-0/+46
|\ \ \ | | | | | | | | | | | | | | | | | | | | | | | | gtkbuilder: add accessibility role declaration Closes #109 See merge request GNOME/gtk!69
| * | | gtkbuilder: add accessibility role declarationSamuel Thibault2018-03-191-0/+46
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This allows to override the role declared to the atk stack. For instance, <accessibility> <role type="static"/> </accessibility> allows to tell the accessibility stack that a label is just a message in a message box. Fixes #109
* | | | gtkstylecontext: guard against gtk_css_widget_node_get_widget() returning ↵Christoph Reiter2018-03-201-1/+5
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | NULL in more places When the widget gets finalized it clears the widgetnode and gtk_css_widget_node_get_widget returns NULL. Guard against gtk_css_widget_node_get_widget() returning NULL like in other places. See https://gitlab.gnome.org/GNOME/pygobject/issues/28#note_82862
* | | | snapshot: Limit cairo nodes to clip regionTimm Bäder2018-03-201-0/+14
| | | | | | | | | | | | | | | | | | | | | | | | In certain cases, we might create large cairo nodes, resulting in surfaces so large, cairo can't handle them. Fix this by limiting the cairo node to the current clip region.
* | | | inspector: Use the attach widget as menu parent objectTimm Bäder2018-03-201-0/+14
| | | | | | | | | | | | | | | | Fixes #101
* | | | progressbar: Remove priv pointerTimm Bäder2018-03-202-56/+45
| | | |
* | | | progressbar: Remove snapshot implementationTimm Bäder2018-03-201-16/+1
| | | |
* | | | levelbar: Remove priv pointerTimm Bäder2018-03-202-71/+101
| | | |
* | | | switch: Avoid a gtk_widget_get_clip callTimm Bäder2018-03-201-1/+0
| | | | | | | | | | | | | | | | | | | | Since we get the correct clip anyway from the gtk_widget_size_allocate call above.
* | | | grid: Remove child listTimm Bäder2018-03-201-183/+153
| | | | | | | | | | | | | | | | | | | | | | | | Save the child info using g_object_set_qdata and just use the widget's built-in child list for everthing else. This is especially simple for GtkGrid since it has never supported reordering its child widgets.
* | | | paned: Remove priv pointerTimm Bäder2018-03-202-70/+59
| | | |
* | | | container: Don't use forall() in compute_expandTimm Bäder2018-03-201-41/+26
| | | | | | | | | | | | | | | | Use the widget list instead, which saves some code.
* | | | container: Don't use forall() in get_request_modeTimm Bäder2018-03-201-31/+24
| |/ / |/| | | | | | | | We can just use the widget child list, which save some code.
* | | gtkimcontextsimple.c: Use X11_DATA_PREFIX only on X11Quentin Glidic2018-03-191-1/+1
|/ / | | | | | | | | | | | | | | | | | | Unlike what commit d01ea18dc3a9acc98fc133ddb53ddc838e4e18f9 says, X11 is not a requirement for Wayland, so a Wayland-only build is possible. We just use the same logic as other non-X11 platforms. https://bugzilla.gnome.org/show_bug.cgi?id=784615 Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
* | mediafile: Improve error messageBenjamin Otte2018-03-191-1/+1
| | | | | | | | | | We are using media plugins these days, so this is not a compile-time issue.
* | video: Add gtk_video_get_file()Benjamin Otte2018-03-191-0/+17
| | | | | | | | That function was missing.
* | gtk: Fix some g-i annotations warningsRico Tzschichholz2018-03-184-7/+7
| |
* | mediastream: Add gtk_media_stream_realize/unrealize()Benjamin Otte2018-03-183-8/+123
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This allows widget to attach their streams to GdkWindow(s) The idea is to allow attaching a stream to windowing system(s) so the stream can make use of its resources, in particular GL contexts. I am however unsure what to attach to: - GtkWindow - GdkWindow - GtkWidget - GskRenderer Each of these provide advantages and disadvantages. So I'm very much open to better suggestions.
* | gtk: Add GtkVideoBenjamin Otte2018-03-186-0/+742
| | | | | | | | | | GtkVideo is a simple video player widget. It probably needs some more configurability, but it does its job.
* | gtk: Add GtkMediaControlsBenjamin Otte2018-03-185-0/+613
| | | | | | | | | | This is a basic first implementation of controls for a GtkMediaStream, modeled after Totem's UI.
* | mediafile: Turn into an extension pointMatthias Clasen2018-03-187-3/+236
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This way, we can support external libraries providing implementations of GtkMediaFile. We also add a media backend called 'nomedia' that can be enabled to not compile any support for GtkMediaFile. This is useful when people want to statically compile GTK into an application that does not use media. For now, this option is the default. We also support a new environment variable GTK_MEDIA that allows selecting the implementation to use. GTK_MEDIA=help can be used to get info about the available implementations.
* | gtk: Add GtkMediaFileBenjamin Otte2018-03-184-0/+613
| | | | | | | | | | | | GtkMediaFile is an implementation of GtkMediaStream to play back files. Except it isn't an implementation yet, but only an interface.
* | gtk: Add GtkMediaStreamBenjamin Otte2018-03-184-0/+1339
| | | | | | | | | | | | | | GtkMediaStream is the new base class for playback of audio and video streams. It implements GdkPaintable for rendering.
* | snapshot: Turn into GObjectBenjamin Otte2018-03-183-45/+44
|/ | | | | | | This makes GdkSnapshot the base class for GtkSnapshot and hopefully stops confusing bindings. C code should see no difference to before.
* texture: Expose subclasses as subclassesBenjamin Otte2018-03-181-1/+1
| | | | | | | | | | This is necessary so that bidnings work properly and don't make gdk_gl_texture_release() a function on GdkTexture. It also allows code to identify what type of texture they are dealing with. Finally, we can now decide to add getters later without screwing anything up, if we want to allow people to access GL textures directly.
* gdk: Remove gdk_texture_new_from_data()Benjamin Otte2018-03-181-4/+2
| | | | Use gdk_memory_texture_new() instead.
* SpinButton: Desensitise +/- buttons as appropriateDaniel Boles2018-03-171-4/+22
| | | | | | | The logic for this in 3 got lost in the move from gadgets to widgets. We must update the sensitivities when :wrap, :value, or the bounds change. Close: https://gitlab.gnome.org/GNOME/gtk/issues/88
* snapshot: Fix some indentationTimm Bäder2018-03-172-8/+8
|
* container: Fix scroll adjustment coordinatesTimm Bäder2018-03-171-1/+1
|
* layout: Fix scrollingTimm Bäder2018-03-171-30/+20
| | | | | We accidentally dropped the code that takes the adjustments into account at some point.
* layout: remove map implementationTimm Bäder2018-03-171-25/+0
| | | | gtk_widget_real_map already maps all the child widgets.
* container: Remove focus widget sorting codeTimm Bäder2018-03-172-442/+0
| | | | The more general version of this code lives in gtkwidgetfocus.s now.
* window: Use widget facilities to sort focus menubarsTimm Bäder2018-03-171-8/+11
|
* menubar: Use GtkWidget focusing facilitiesTimm Bäder2018-03-171-17/+21
|