summaryrefslogtreecommitdiff
path: root/gtk/gtktoolitem.c
Commit message (Collapse)AuthorAgeFilesLines
* toolitem: fix a copy/paste typoCosimo Cecchi2015-12-291-1/+1
|
* toolitem: Set a css nameMatthias Clasen2015-12-081-0/+2
|
* toolitem: set clip on allocationCosimo Cecchi2014-09-031-1/+3
| | | | | So that widgets that are children of tool items can render their shadows too.
* GtkToolItem: Use G_PARAM_EXPLICIT_NOTIFYMatthias Clasen2014-06-091-3/+3
|
* docs: use Returns: consistentlyWilliam Jon McCann2014-02-191-18/+18
| | | | Instead of Return value:
* Docs: Remove all entities and turn off sgml modeMatthias Clasen2014-02-091-3/+3
| | | | | With all element markup gone, it is time to turn off sgml mode, and get rid of entities as well.
* docs: use proper quotesWilliam Jon McCann2014-02-051-2/+2
|
* Docs: Use markdown for listsMatthias Clasen2014-02-021-46/+22
| | | | This greatly reduces the amount of xml in the docs.
* Move wholly deprecated classes to gtk/deprecated/Matthias Clasen2013-07-191-1/+1
| | | | | | | | | | | | | | | | | | We've recently a number of classes wholly. For these cases, move the headers and sources to gtk/deprecated/ and adjust Makefiles and includes accordingly. Affected classes: GtkAction GtkActionGroup GtkActivatable GtkIconFactory GtkImageMenuItem GtkRadioAction GtkRecentAction GtkStock GtkToggleAction GtkUIManager
* gtk: Use new macros for defining private dataEmmanuele Bassi2013-07-091-7/+2
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=702996
* Deprecate GtkAction and GtkUIManagerWilliam Jon McCann2013-06-301-2/+23
| | | | It is recommended to use GAction et al and GtkBuilder.
* docs: correct various spelling and grammar errorsWill Thompson2013-03-041-1/+1
| | | | | I noticed a few cases of "wether", and while fixing them noticed a few "its" which should be "it's". It all went downhill from there.
* Add gtk_widget_(un)register_windowAlexander Larsson2013-02-071-2/+2
| | | | | | | | | | | | This replaces the previously hardcoded calls to gdk_window_set_user_data, and also lets us track which windows are a part of a widget. Old code should continue working as is, but new features that require the windows may not work perfectly. We need this for the transparent widget support to work, as we need to specially mark the windows of child widgets. https://bugzilla.gnome.org/show_bug.cgi?id=687842
* Chain up relevant GObjectClass:notify vfuncsClaudio Saavedra2012-08-071-0/+3
| | | | | | | | These widgets have ancestors other than GObject which could eventually implement the notify vfunc for their properties. For correctness, they should chain up the notify vfunc. https://bugzilla.gnome.org/show_bug.cgi?id=673478
* docs: fix a number of typos and obsolete referencesCosimo Cecchi2012-07-021-5/+2
|
* Change FSF AddressJavier Jardón2012-02-271-3/+1
|
* Documentation: Correct references to properties.Murray Cumming2012-02-151-1/+1
| | | | | | | | These should use :, not ::, though signals would use ::. See http://developer.gnome.org/gtk-doc-manual/unstable/documenting_syntax.html.en and http://developer.gnome.org/gtk-doc-manual/unstable/documenting_symbols.html.en
* gtk: move _gtk_modules_has_mixed_deps() to gtkmodlesprivate.hMichael Natterer2011-10-231-1/+0
| | | | and remove gtkmainprivate.h completely.
* GtkToolItemPrivate: Improve struct packingMatthias Clasen2011-04-121-9/+8
|
* Move docs for gtkmain inlineMatthias Clasen2011-01-041-1/+1
| | | | | | | | At the same time, introduce a gtkmainprivate.h header and various other cleanups. Based on a patch by Tadej Borovšak. https://bugzilla.gnome.org/show_bug.cgi?id=617471
* GtkToolItem: Remove unneeded callCarlos Garnacho2011-01-041-2/+0
|
* Remove size_request from gtkToolItemMatthias Clasen2010-10-301-35/+45
|
* Move GtkSizeRequest into GtkWidgetBenjamin Otte2010-09-261-2/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | It doesn't make sense to keep them separate as GtkSizeRequest requires a GtkWidget and GtkWidget implements GtkSizeRequest, so you can never have one without the other. It also makes the code a lot easier because no casts are required when calling functions. Also, the names would translate to gtk_widget_get_width() and people agreed that this would be a too generic name, so a "preferred" was added to the names. So this patch moves the functions: gtk_size_request_get_request_mode() => gtk_widget_get_request_mode() gtk_size_request_get_width() => gtk_widget_get_preferred_width() gtk_size_request_get_height() => gtk_widget_get_preferred_height() gtk_size_request_get_size() => gtk_widget_get_preferred_size() gtk_size_request_get_width_for_height() => gtk_widget_get_preferred_width_for_height() gtk_size_request_get_height_for_width() => gtk_widget_get_preferred_height_for_width() ... and moves the corresponding vfuncs to the GtkWidgetClass. The patch also renames the implementations of the vfuncs in widgets to include the word "preferrred".
* Tons of transfer annotationsMatthias Clasen2010-09-211-13/+15
|
* Use gtk_size_request_get_size() instead deprecated gtk_widget_size_request()Javier Jardón2010-09-151-2/+5
| | | | | | | Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629598 Signed-off-by: Javier Jardón <jjardon@gnome.org> Signed-off-by: Tristan Van Berkom <tristanvb@openismus.com>
* gtk/gtktoolitem.c: use accessor functions to access GtkWidgetJavier Jardón2010-08-221-26/+34
|
* GtkToolItem: unseal private pointerJavier Jardón2010-07-141-2/+3
|
* Use GtkBin accessorsJavier Jardón2010-07-131-6/+6
|
* Use accessor functions to acces GtkContainerJavier Jardón2010-07-131-5/+7
|
* gtk/: fully remove gtkalias hacksJavier Jardón2010-07-101-4/+1
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=623845
* Move documentation to inline comments: GtkToolItemJavier Jardón2010-05-131-0/+1
|
* Remove deprecated GtkTooltipsChristian Dywan2010-05-031-2/+0
|
* [gtk/gtktoolitem] Remove deprecated GtkToolItem stuffJavier Jardón2010-05-031-21/+0
| | | | This completes 221dcb6955cb89d1f89e71f442fc4c42fb76fcf3
* Remove deprecated GtkToolItem functionsChristian Dywan2010-05-031-57/+0
|
* Don't use GTK_WIDGET_*SET_FLAGS (wid, GTK_REALIZED)Javier Jardón2010-03-061-1/+1
| | | | | | Use new API instead: gtk_widget_set_realized () https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_REALIZEDJavier Jardón2010-03-031-1/+2
| | | | | | Use gtk_widget_get_realized() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_MAPPEDJavier Jardón2010-03-031-1/+1
| | | | | | Use gtk_widget_get_mapped() instead. https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Don't use GTK_WIDGET_*SET_FLAGS (wid, GTK_CAN_FOCUS)Javier Jardón2010-03-021-1/+1
| | | | Use new API instead: gtk_widget_set_can_focus ()
* Deprecate widget flag: GTK_WIDGET_VISIBLEJavier Jardón2010-03-011-2/+2
| | | | | | Use gtk_widget_get_visible() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_SENSITIVEJavier Jardón2010-03-011-2/+2
| | | | | | Use gtk_widget_get_sensitive() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Change GtkIconSize to int in params/return valuesDan Winship2009-12-191-1/+2
| | | | | | | | | GtkIconSize is an extensible enumeration (via gtk_icon_size_register()), so methods that claim to take/return a GtkIconSize need to actually use "int" to work correctly with bindings that are strict about enum values. https://bugzilla.gnome.org/show_bug.cgi?id=604895
* [introspection] Merge in Gtk-custom.c annotationsColin Walters2009-12-161-6/+6
| | | | | | | | The Gtk-custom.c file in gir-repository contained a number of introspection annotations. Merge those into the GTK source files. Some documentation was moved from the tmpl/ files to accomodate the addition of annotations.
* Fix gtk_tool_item_get_text_size_group return valueMatthias Clasen2009-12-131-1/+1
| | | | Reported by Kazuki Iwamoto in bug 604462.
* Fix small documentation problems after the toolpalette mergeMatthias Clasen2009-11-281-22/+22
| | | | | Several Since tags were wrong. Spotted by Christian Persch in bug 603268.
* Fix a doc commentMatthias Clasen2009-11-271-7/+6
|
* Merge branch 'master' into toolpaletteJohannes Schmid2009-10-281-0/+16
|\
| * docs: inline see_also to sections docs and add missing <variablelist>Stefan Kost2009-07-281-0/+16
| | | | | | | | This fixes docbook validation for the file.
* | ToolShell: Add ellipsize, text-orientation, text-alignment and size-group.Murray Cumming2009-07-131-0/+106
|/ | | | | | | | | | | | | * gtk/gtktoolshell.c: Added vfuncs to get/set ellipsize, text-orientation, text-alignment and size-group plus getter/setters to invoke these vfuncs. * gtk/gtktoolitem.[h|c]: Added getters and setters to get/set these from the parent GtkToolShell. This is in the style of the existing "properties". * gtk/gtktoolbutton.c: Updated to use the extra properties. * docs/reference/gtk/gtk-sections.txt * gtk/gtk.symbols: Updated to mention the new functions. These new "properties" are used by GtkToolPalette.
* Rename gtk_activatable_reset to gtk_activatable_sync_action_properties,Matthias Clasen2009-02-221-16/+16
| | | | | | | | | | * gtk/gtk.symbols: * gtk/gtkactivatable.[hc]: Rename gtk_activatable_reset to gtk_activatable_sync_action_properties, since the previous name was deemed too generic. Update all implementations. svn path=/trunk/; revision=22389
* More action-related fixesMatthias Clasen2009-01-261-5/+5
| | | | svn path=/trunk/; revision=22218