| Commit message (Collapse) | Author | Age | Files | Lines |
... | |
|
|
|
| |
request time).
|
|
|
|
|
|
| |
As gtk_adjustment_new() returns a GtkAdjustment* now
https://bugzilla.gnome.org/show_bug.cgi?id=630731
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
It doesn't make sense to keep them separate as GtkSizeRequest requires a
GtkWidget and GtkWidget implements GtkSizeRequest, so you can never have
one without the other.
It also makes the code a lot easier because no casts are required when
calling functions.
Also, the names would translate to gtk_widget_get_width() and people
agreed that this would be a too generic name, so a "preferred" was added
to the names.
So this patch moves the functions:
gtk_size_request_get_request_mode() => gtk_widget_get_request_mode()
gtk_size_request_get_width() => gtk_widget_get_preferred_width()
gtk_size_request_get_height() => gtk_widget_get_preferred_height()
gtk_size_request_get_size() => gtk_widget_get_preferred_size()
gtk_size_request_get_width_for_height() =>
gtk_widget_get_preferred_width_for_height()
gtk_size_request_get_height_for_width() =>
gtk_widget_get_preferred_height_for_width()
... and moves the corresponding vfuncs to the GtkWidgetClass.
The patch also renames the implementations of the vfuncs in widgets to
include the word "preferrred".
|
| |
|
|
|
|
|
| |
Colormaps are about to be removed, so not using them sounds like an
awesome idea.
|
|
|
|
| |
These calls aren't necessary anymore.
|
| |
|
|
|
|
|
|
|
| |
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629598
Signed-off-by: Javier Jardón <jjardon@gnome.org>
Signed-off-by: Tristan Van Berkom <tristanvb@openismus.com>
|
|
|
|
|
|
| |
gtk_widget_get_child_requisition()
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629177
|
| |
|
| |
|
| |
|
|
|
|
| |
https://bugzilla.gnome.org/show_bug.cgi?id=623845
|
| |
|
|
|
|
|
|
| |
Use new API instead: gtk_widget_set_mapped ()
https://bugzilla.gnome.org/show_bug.cgi?id=69872
|
|
|
|
|
|
| |
Use new API instead: gtk_widget_set_realized ()
https://bugzilla.gnome.org/show_bug.cgi?id=69872
|
|
|
|
|
|
| |
Use gtk_widget_get_realized() instead
https://bugzilla.gnome.org/show_bug.cgi?id=69872
|
|
|
|
|
|
| |
Use gtk_widget_get_mapped() instead.
https://bugzilla.gnome.org/show_bug.cgi?id=69872
|
|
|
|
|
|
| |
Use gtk_widget_get_visible() instead
https://bugzilla.gnome.org/show_bug.cgi?id=69872
|
|
|
|
|
|
|
|
| |
This commit was created using a script that searched for all docstrings
containing a parameter and the string 'or %NULL'.
Gdk backends and demos excluded as they are not part of a public API
https://bugzilla.gnome.org/show_bug.cgi?id=610474
|
|
|
|
|
|
|
|
| |
The Gtk-custom.c file in gir-repository contained a number of
introspection annotations. Merge those into the GTK source files.
Some documentation was moved from the tmpl/ files to accomodate
the addition of annotations.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-12-11 Sven Herzberg <sven@imendio.com>
Document the "set-scroll-adjustments" signal
Reviewed by Kristian Rietveld.
* gtk/gtkiconview.c,
* gtk/gtklayout.c,
* gtk/gtktextview.c,
* gtk/gtktreeview.c,
* gtk/gtkviewport.c: added proper documentation for the signal
svn path=/trunk/; revision=21871
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-08-12 Michael Natterer <mitch@imendio.com>
* gtk/gtkaccellabel.c
* gtk/gtkcalendar.c
* gtk/gtkclist.c
* gtk/gtkentry.c
* gtk/gtkeventbox.c
* gtk/gtkfilechooserbutton.c
* gtk/gtkfilechooserdefault.c
* gtk/gtkhandlebox.c
* gtk/gtkhsv.c
* gtk/gtkiconview.c
* gtk/gtkimage.c
* gtk/gtklayout.c
* gtk/gtklistitem.c
* gtk/gtkmenuitem.c
* gtk/gtkmessagedialog.c
* gtk/gtknotebook.c
* gtk/gtkpaned.c
* gtk/gtkpathbar.c
* gtk/gtkplug.c
* gtk/gtkprintunixdialog.c
* gtk/gtkrange.c
* gtk/gtkrecentchooserdefault.c
* gtk/gtkruler.c
* gtk/gtksocket.c
* gtk/gtktext.c
* gtk/gtktextview.c
* gtk/gtktoolbar.c
* gtk/gtktreeitem.c
* gtk/gtktreeview.c
* gtk/gtkviewport.c
* gtk/gtkwin32embedwidget.c: chain up unconditionally in
realize(), unrealize(), map(), unmap(), style_set(),
key_press_event() and size_request()
svn path=/trunk/; revision=21088
|
|
|
|
|
|
|
|
|
|
|
| |
2008-08-12 Michael Natterer <mitch@imendio.com>
* gtk/*.c: consistently chain up using
GTK_FOO_CLASS(parent_class)->bar(instance) instead of
(*GTK_FOO_CLASS(parent_class))->bar(instance).
svn path=/trunk/; revision=21085
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-08-11 Sven Neumann <sven@gimp.org>
* gtk/gtklabel.c
* gtk/gtklayout.c
* gtk/gtklist.c
* gtk/gtklistitem.c: use canonical signal names.
svn path=/trunk/; revision=21064
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-08-08 Sven Neumann <sven@gimp.org>
* gtk/gtkadjustment.c
* gtk/gtkclist.c
* gtk/gtkcolorsel.c
* gtk/gtkiconview.c
* gtk/gtklayout.c
* gtk/gtkprogress.c
* gtk/gtkrange.c
* gtk/gtkspinbutton.c
* gtk/gtktext.c
* gtk/gtktextview.c
* gtk/gtktreeview.c
* gtk/gtkviewport.c: use the canonical signal name
"value-changed"
instead of "value_changed".
svn path=/trunk/; revision=21041
|
|
|
|
| |
svn path=/trunk/; revision=20724
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-06-30 Cody Russell <bratsche@gnome.org>
* Practically everything changed.
Change all references of GIMP Toolkit (and variations of it)
to GTK+ Toolkit, showing no mercy at all to our beloved
ancestry. (#540529)
svn path=/trunk/; revision=20709
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-06-21 Johan Dahlin <jdahlin@async.com.br>
* *.[ch]: Include "config.h" instead of <config.h>
Command used:
find -name \*.[ch]|xargs perl -p -i -e 's/^#include <config.h>/#include "config.h"/g'
Rubberstamped by Mitch and Tim
svn path=/trunk/; revision=20669
|
|
|
|
|
|
|
|
|
| |
2008-06-20 Johan Dahlin <jdahlin@async.com.br>
* gtk/gtklayout.c (enum): Remove left-over unused property enum.
svn path=/trunk/; revision=20649
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-06-20 Johan Dahlin <jdahlin@async.com.br>
* gtk/gtkaccelgroup.c:
* gtk/gtkcolorseldialog.c:
* gtk/gtkcontainer.c:
* gtk/gtkdialog.c:
* gtk/gtkentry.c (gtk_entry_class_init):
* gtk/gtkfontsel.c:
* gtk/gtkhandlebox.c:
* gtk/gtklayout.c:
* gtk/gtkmenu.c (gtk_menu_class_init):
* gtk/gtkmenuitem.c (gtk_menu_item_class_init):
* gtk/gtkplug.c (gtk_plug_class_init):
* gtk/gtkselection.c:
* gtk/gtksocket.c:
* gtk/gtktreeselection.c:
* gtk/gtkwidget.c (gtk_widget_class_init):
* gtk/gtkwindow.c:
Add missing Since: gtk-doc markup for newly added GSEAL API.
Change all Since: GSEAL-branch to Since: 2.14.
svn path=/trunk/; revision=20639
|
|
|
|
| |
svn path=/trunk/; revision=20588
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2008-02-07 Michael Natterer <mitch@imendio.com>
* gtk/gtkcellview.c
* gtk/gtklabel.c
* gtk/gtklayout.c
* gtk/gtklist.c
* gtk/gtkmenu.c
* gtk/gtkmenushell.c
* gtk/gtkmisc.c
* gtk/gtkoptionmenu.c
* gtk/gtkplug.c
* gtk/gtkpreview.c
* gtk/gtkprogress.c
* gtk/gtkradiomenuitem.c
* gtk/gtkscale.c
* gtk/gtkscrolledwindow.c
* gtk/gtksocket.c: remove g_return_if_fail() from private
functions and virtual function implementations.
svn path=/trunk/; revision=19492
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Mon May 15 15:12:05 2006 Søren Sandmann <sandmann@redhat.com>
* gtk/gtklayout.c (gtk_layout_realize),
* gtk/gtkiconview.c (gtk_icon_view_realize),
* gtk/gtktreeview.c (gtk_tree_view_realize): Set the background of
the clip windows to NULL, since they are generally invisible and
don't have EXPOSURE set, which means they temp-unvlicker code
doesn't apply to them.
* gdk/x11/gdkgeometry-x11.c (_gdk_window_move_resize_child): Unset
the background of the parent window during resizing. Invalidate
the uncoered area of the parent window. Bug 341332.
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Wed Nov 23 18:55:47 2005 Tim Janik <timj@imendio.com>
* gtk/gtkobject.[hc]: deprecated floating/sink API and implemented it
in terms of the GObject floating/sink API.
* gtk/gtkaboutdialog.c:
* gtk/gtkaction.c:
* gtk/gtkcellview.c:
* gtk/gtkclist.c:
* gtk/gtkcolorsel.c:
* gtk/gtkcombobox.c:
* gtk/gtkfilechooserdefault.c:
* gtk/gtkiconview.c:
* gtk/gtkinvisible.c:
* gtk/gtkitemfactory.c:
* gtk/gtklayout.c:
* gtk/gtkmenu.c:
* gtk/gtkmenutoolbutton.c:
* gtk/gtknotebook.c:
* gtk/gtkprogress.c:
* gtk/gtkrange.c:
* gtk/gtkspinbutton.c:
* gtk/gtkstatusicon.c:
* gtk/gtktext.c:
* gtk/gtktextview.c:
* gtk/gtktoolbar.c:
* gtk/gtktoolbutton.c:
* gtk/gtktoolitem.c:
* gtk/gtktreeitem.c:
* gtk/gtktreeview.c:
* gtk/gtktreeviewcolumn.c:
* gtk/gtkuimanager.c:
* gtk/gtkviewport.c:
* gtk/gtkwidget.c:
* gtk/gtkwindow.c:
ported to use GObject's g_object_ref_sink().
* gtk/gtkcolorsel.c:
* gtk/gtkfilechooserdefault.c:
* gtk/gtkaboutdialog.c:
fixed compiler warnings.
|
|
|
|
|
|
| |
2005-09-13 Matthias Clasen <mclasen@redhat.com>
* gtk/*.c: Various cleanups. (#315360, Kjartan Maraas)
|
|
|
|
|
|
|
|
|
| |
2005-09-01 Matthias Clasen <mclasen@redhat.com>
* gdk/*.c: Intern some more strings.
* gtk/gtkintl.h:
* gtk/*.c: Define an I_() macro and use it instead of the
bulky g_intern_static_string().
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2005-08-31 Matthias Clasen <mclasen@redhat.com>
* gdk/Makefile.am:
* gtk/Makefile.am: Intern type names in code generated by
glib-mkenums, too.
* gtk/*.c:
* gdk/x11/*.c:
* gdk/*.c: Intern type names before registering the type to avoid
unnecessary copies.
|
|
|
|
|
|
|
|
|
|
|
|
| |
2005-03-21 Matthias Clasen <mclasen@redhat.com>
* gtk/gtkprivate.h: Define macros GTK_PARAM_READABLE,
GTK_PARAM_WRITABLE, GTK_PARAM_READWRITE which are like
their G_ counterparts, but also mark the name, nick
and blurb as static.
* gtk/*.c: Mark param spec strings as static, using
the new macros.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2005-03-20 Matthias Clasen <mclasen@redhat.com>
Make PLT-reduction work with gcc4, and don't include
everything in gdkalias.h:
* gtk/grk.symbols: Group symbols by header and source file.
* gtk/makegtkalias.pl: Protect definitions by the same
preprocessor symbols used to guard the headers. Move
the alias declarations to a separate file which is
produced when calling makegtkalias.pl -def
* gdk/Makefile.am (gtkaliasdef.c): Add a rule to generate
this file.
* gtk/*.c: Include gtkalias.h after the other headers,
include gtkaliasdef.c at the bottom.
* gtk/*.h: Small cleanups.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Mon Aug 9 12:48:04 2004 Matthias Clasen <maclas@gmx.de>
Add hidden aliases for exported symbols which are
used internally in order to get rid of many PLT
entries. (#145519, Arjan van de Ven)
* gtk/Makefile.am: Add rules to generate gtk.def and
from gtk.symbols, and make make check check the abi
with abicheck.sh.
(gtk_private_h_sources): Add gtkinternals.h
(gtk_built_private_headers): Add gtkalias.h
(gtk_extra_sources): Add gtk.symbols
(EXTRA_DIST): Add makegtkalias.pl and abicheck.sh
* gtk/gtk.symbols: New file. Definition of the GTK+ ABI.
The file can be processed by cpp to filter out certain
subsets of symbols.
* gtk/abicheck.sh: New file. Script to check the actually
symbols exported from libgtk-x11.2.0.so against the symbols
found in gtk.symbols.
* gtk/makegtkalias.pl: New file. Perl script to generate the
header containing the alias definitions for internally used
exported symbols from a list of symbols.
* gtk/gtkinternals.h: New file. An uninstalled header listing
symbols which must be exported for some reason and do not appear
in any other header.
* gtk/*.c: Include gtkalias.h
|
|
|
|
|
|
|
| |
* gtk/gtklayout.c (gtk_layout_add): added a default method for the add
virtual method of GtkContainer.
(gtk_layout_class_init): assign gtk_layout_add to the 'add' virtual
method slot of the container class.
|
|
|
|
|
|
|
|
|
|
| |
2004-03-05 Federico Mena Quintero <federico@ximian.com>
Fixes #136082 and #135265, patch by Morten Welinder.
* configure.in: Use AC_SYS_LARGEFILE.
* */*.c: #include <config.h>
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Fri Jan 16 23:59:01 2004 Matthias Clasen <maclas@gmx.de>
The first part of the fix for #114351 (see also
gdk-pixbuf/ChangeLog and po/ChangeLog):
* gtk/gtkintl.h:
* gdk-pixbuf/gdk-pixbuf-i18n.h:
* gdk/gdkintl.h: Define P_() for property blurbs and nicks.
* gdk/gdkdisplaymanager.c:
* gdk-pixbuf/gdk-pixbuf.c:
* modules/input/gtkimcontextxim.c:
* gtk/*.c: Mark property blurbs and nicks with P_().
* po/Makefile.in.in: Add --keyword=P_ to the xgettext
invocation, since property blurbs and nicks are
now marked with P_().
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Sun Oct 13 13:43:16 2002 Manish Singh <yosh@gimp.org>
* gtk/gtkcurve.[ch] gtk/gtkgamma.[ch] gtk/gtklayout.[ch]
gtk/gtkwidget.[ch] modules/input/gtkimcontextxim.c
modules/input/imam-et.c modules/input/imcyrillic-translit.c
modules/input/imhangul.c modules/input/iminuktitut.c
modules/input/imipa.c modules/input/imthai-broken.c
modules/input/imti-er.c modules/input/imti-et.c
modules/input/imviqr.c: Deprecation cleanup
* modules/input/Makefile.am: Added disable deprecation flags
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
2002-08-10 Soren Sandmann <sandmann@daimi.au.dk>
* docs/reference/gtk/tree_widget.sgml,
docs/reference/gtk/tmpl/gtkdialog.sgml,
docs/reference/gtk/tmpl/gtkentry.sgml,
docs/reference/gtk/tmpl/gtkfilesel.sgml,
docs/reference/gtk/tmpl/gtkfontsel.sgml,
docs/reference/gtk/tmpl/gtkfontseldlg.sgml,
docs/reference/gtk/tmpl/gtktreemodel.sgml,
docs/reference/gtk/tmpl/gtkwidget.sgml, gdk/x11/gdkdisplay-x11.c,
gtk/gtkbbox.c, gtk/gtkbox.c, gtk/gtkbutton.c, gtk/gtkcellrenderer.c,
gtk/gtkcellrendererpixbuf.c, gtk/gtkcellrenderertext.c,
gtk/gtkcheckmenuitem.c, gtk/gtkcontainer.c, gtk/gtkcurve.c,
gtk/gtkdialog.h, gtk/gtkentry.c, gtk/gtkfilesel.c, gtk/gtkfontsel.c,
gtk/gtkframe.c, gtk/gtkhandlebox.c, gtk/gtkiconfactory.c,
gtk/gtkimage.c, gtk/gtkinvisible.c, gtk/gtkitemfactory.c,
gtk/gtklabel.c, gtk/gtklayout.c, gtk/gtkmenu.c, gtk/gtkprogress.c,
gtk/gtkprogressbar.c, gtk/gtkscrolledwindow.c, gtk/gtksizegroup.c,
gtk/gtktable.c, gtk/gtktextiter.c, gtk/gtktexttag.c,
gtk/gtktexttag.h, gtk/gtktextview.c, gtk/gtktogglebutton.c,
gtk/gtktoolbar.c, gtk/gtktreemodel.c, gtk/gtktreeselection.c,
gtk/gtktreestore.c, gtk/gtktreeview.c, gtk/gtktreeviewcolumn.c,
gtk/gtkviewport.c, gtk/gtkwidget.c, gtk/gtkwidget.h,
gtk/gtkwindow.c:
Minor documentation fixes
(#89254, patch from Brett Nash;
#85809, patch from daten@dnetc.org;
#76391, patch from Ross Burton;
#74559, Manuel Clos;
#73569, #72005, Alexey A. Malyshev;
#70061, patch from Dennis Bj"orklund;
#64566, #63388, #58328, #57499, #81007, #77349, Vitaly Tishkov;
#78932, Vitaly Tishkov, patch from Ross Burton;
#73306)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Tue May 14 15:09:33 2002 Owen Taylor <otaylor@redhat.com>
* gdk/x11/gdkkeys-x11.c: Try adding a #ifndef/#define
for XkbKeySymEntry to make up for OSF broken
XKB extension. (#77819, Gareth Pearce)
* gtk/gtklayout.c: Clamp the upper values in response
to ::size-allocate if necessary. (#81290, Christophe Saout)
* gtk/gtkcombo.c (gtk_combo_entry_focus_out): Handle
combo being destroyed before idle fires.
(#81396, Timo Sirainen)
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Mon Feb 18 14:17:59 2002 Owen Taylor <otaylor@redhat.com>
* gtk/gtkclist.c (adjust_adjustments)
* gtk/gtklayout.c (gtk_layout_size_allocate)
* gtk/gtktextview.c (gtk_text_view_size_allocate)
* gtk/gtktreeview.c (gtk_tree_view_size_allocate)
* gtk/gtkviewport.c (gtk_viewport_size_allocate):
Standardize on a page increment of page minus 1 line
rather than half a page (#51027, Eric Fischer)
* gtk/gtkviewport.c (gtk_viewport_size_allocate):
Change step increment to be 0.1 * page_size height rather than
a fixed 10 pixels.
|