summaryrefslogtreecommitdiff
path: root/gtk/gtkhandlebox.c
Commit message (Collapse)AuthorAgeFilesLines
* Move wholly deprecated files to a subdirectoryMatthias Clasen2011-11-011-1636/+0
| | | | Also install their headers to a subdirectory.
* Don't use *DISABLE_DEPRECATED guardsMatthias Clasen2011-11-011-1/+0
| | | | Instead define GDK_DISABLE_DEPRECATION_WARNINGS where appropriate.
* handlebox: Define GDK_DISABLE_DEPRECATION_WARNINGSBenjamin Otte2011-11-021-0/+1
|
* handlebox: DeprecateBenjamin Otte2011-09-301-0/+28
|
* Move documentation to inline comments: GtkHandleBoxJavier Jardón2011-04-141-8/+101
|
* Always chain up in ::style-updatedMatthias Clasen2011-02-071-0/+2
| | | | | This was not handled consistently, but the default handler does useful things, so we should always chain up.
* Silence new gcc warningsMatthias Clasen2011-01-231-31/+21
| | | | | gcc 4.6.0 has started to warn about set-but-unused variables. So don't do that, then.
* Remove gtktypeutils altogetherMatthias Clasen2011-01-041-0/+3
| | | | | | Based on patches by Javier Jardón. https://bugzilla.gnome.org/show_bug.cgi?id=629955
* Make GtkHandleBox size request code use GtkStyleContext for paddingCarlos Garnacho2011-01-041-2/+10
|
* Make GtkHandleBox use GtkStyleContextCarlos Garnacho2010-12-281-62/+67
|
* API: gdk: gdk_display_get_device_state() => gdk_device_get_position()Benjamin Otte2010-12-271-4/+3
| | | | | The API was not display-specific, but belonged to the device. Also, we didn't find a user of the modifier mask, so we dropped it.
* gtk: Use g_object_unref instead of gdk_cursor_unrefBenjamin Otte2010-12-211-1/+1
|
* Add invariant that a child is unmapped if parent is unmappedHavoc Pennington2010-12-201-0/+2
| | | | | | | | | | | | | Requires fixes to GtkContainer and GtkWindow to unmap their children, rather than just withdrawing or hiding the container window. Requires fix to GtkHandleBox to chain up to GtkContainer unmap. Historically we avoided these unmaps for efficiency reasons, but these days it's a bigger problem that there's no way for child widgets to know that one of their ancestors has become unmapped.
* Remove size_request from GtkHandleBoxTristan Van Berkom2010-10-301-1/+33
|
* Move GtkSizeRequest into GtkWidgetBenjamin Otte2010-09-261-8/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | It doesn't make sense to keep them separate as GtkSizeRequest requires a GtkWidget and GtkWidget implements GtkSizeRequest, so you can never have one without the other. It also makes the code a lot easier because no casts are required when calling functions. Also, the names would translate to gtk_widget_get_width() and people agreed that this would be a too generic name, so a "preferred" was added to the names. So this patch moves the functions: gtk_size_request_get_request_mode() => gtk_widget_get_request_mode() gtk_size_request_get_width() => gtk_widget_get_preferred_width() gtk_size_request_get_height() => gtk_widget_get_preferred_height() gtk_size_request_get_size() => gtk_widget_get_preferred_size() gtk_size_request_get_width_for_height() => gtk_widget_get_preferred_width_for_height() gtk_size_request_get_height_for_width() => gtk_widget_get_preferred_height_for_width() ... and moves the corresponding vfuncs to the GtkWidgetClass. The patch also renames the implementations of the vfuncs in widgets to include the word "preferrred".
* handlebox: Get rid of gdk_drawable_get_size() usageBenjamin Otte2010-09-261-11/+8
|
* API: Rename gtk_cairo_paint_*() to gtk_paint_*()Benjamin Otte2010-09-261-5/+5
| | | | | | Large patch, but just renaming. Indentation should still mostly be correct because I took care of keeping the indentation for this function name.
* Change semantics of the draw signalBenjamin Otte2010-09-261-12/+2
| | | | | | | | | | | | | | | | | | | Previously, we tried to move the context's origin to the widget's top left location, no matter what window the paint was happening on. Now we only do that for child windows of the widget's window and leave the context untouched for windows that the widget has created outside its own hierarchy. In those casses, we also don't clip the context to the widget's allocation. Includes fixes to GtkHandlebox for this effect and fixes all known issues with it. These semantics assume that gtk_widget_draw() should only draw the parts of a widget that are inside child windows and not draw stuff that is located in completely different GdkWindows. In the handlebox case, it means that it should only draw the handle when it is attached, but not when it isn't. We'll likely need a special draw function for the detached handlebox if we want to draw it.
* handlebox: Port to draw vfuncBenjamin Otte2010-09-261-55/+62
|
* handlebox: Simplify painting codeBenjamin Otte2010-09-261-44/+15
|
* handlebox: Don't draw outside of expose eventsBenjamin Otte2010-09-261-1/+0
| | | | We do a queue_draw() via queue_resize() here, so everything's fine.
* gtk: Don't set colormap anymore when creating GDK windowsBenjamin Otte2010-09-261-5/+3
| | | | | Colormaps are about to be removed, so not using them sounds like an awesome idea.
* Use gdk_window_set_background_pattern() to set parent-relative bakgroundBenjamin Otte2010-09-261-1/+0
|
* Use gtk_size_request_get_size() instead deprecated gtk_widget_size_request()Javier Jardón2010-09-151-1/+4
| | | | | | | Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629598 Signed-off-by: Javier Jardón <jjardon@gnome.org> Signed-off-by: Tristan Van Berkom <tristanvb@openismus.com>
* Use gtk_size_request_get_size() instead deprecated ↵Javier Jardón2010-09-131-2/+8
| | | | | | gtk_widget_get_child_requisition() Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629177
* gtk/gtkhandlebox.c: Do not use gdk_window_get_deskrelative_origin()Javier Jardón2010-09-091-10/+0
| | | | This completes commit bd277fad50704f6a39619cb418204bdfee112b98
* gtk/gtkhandlebox.c: use accessor functions to access GtkWidgetJavier Jardón2010-09-081-70/+96
|
* Completely removed requisition cache from GtkWidget instance structure.Tristan Van Berkom2010-09-081-2/+6
| | | | | | | | | | | | | | Since we have a new mechanism for requesting sizes: GtkSizeRequestIface; it makes no sense to maintain this cache on the GtkWidget structure... removing the requisition cache however does not break the old "size-request" signal which is there for backwards compatability reasons. In any case widget->requisition should not have been accessed, gtk_widget_get_child_requisition() would have been the correct way to consult the cache. This commit also deprecates the newly added gtk_widget_get_requisition() API and makes it fallback on gtk_size_request_get_size().
* Remove deprecated 'shadow' properties in GtkFrame and GtkHandleBoxMatthias Clasen2010-08-281-10/+0
|
* Use GtkFooPrivate instead GtkFooPrivJavier Jardón2010-08-271-25/+25
|
* Check if childs actually exists before using itJavier Jardón2010-07-221-3/+6
| | | | | | Check seems to have gone lost during GtkBin sealing in commit 4427760b Fixes https://bugzilla.gnome.org/show_bug.cgi?id=624707
* gtkhandlebox: move public members to private structureJavier Jardón2010-07-131-204/+238
|
* Use GtkBin accessorsJavier Jardón2010-07-131-22/+36
|
* Use accessor functions to acces GtkContainerJavier Jardón2010-07-131-7/+16
|
* gtk/: fully remove gtkalias hacksJavier Jardón2010-07-101-4/+1
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=623845
* Merge the xi2-for-master branchMatthias Clasen2010-05-251-15/+23
|
* Don't use GTK_WIDGET_STATE in internal code anymoreJavier Jardón2010-03-091-8/+8
| | | | | | Use gtk_widget_get/set_state() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Don't use GTK_WIDGET_*SET_FLAGS (wid, GTK_MAPPED)Javier Jardón2010-03-061-2/+2
| | | | | | Use new API instead: gtk_widget_set_mapped () https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Don't use GTK_WIDGET_*SET_FLAGS (wid, GTK_REALIZED)Javier Jardón2010-03-061-1/+1
| | | | | | Use new API instead: gtk_widget_set_realized () https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Don't use GTK_WIDGET_*SET_FLAGS (wid, GTK_NO_WINDOW)Javier Jardón2010-03-061-1/+1
| | | | | | Use new API instead: gtk_widget_set_has_window () https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_REALIZEDJavier Jardón2010-03-031-5/+5
| | | | | | Use gtk_widget_get_realized() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_MAPPEDJavier Jardón2010-03-031-1/+1
| | | | | | Use gtk_widget_get_mapped() instead. https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_VISIBLEJavier Jardón2010-03-011-3/+3
| | | | | | Use gtk_widget_get_visible() instead https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate widget flag: GTK_WIDGET_DRAWABLEJavier Jardón2010-03-011-1/+1
| | | | | | Use gtk_widget_is_drawable() instead. https://bugzilla.gnome.org/show_bug.cgi?id=69872
* Deprecate flag macros for toplevel, state, no window and composite childChristian Dywan2010-01-041-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | Deprecate widget flag macros GTK_WIDGET_STATE, GTK_WIDGET_SAVED_STATE, GTK_WIDGET_FLAGS, GTK_WIDGET_TOPLEVEL, GTK_WIDGET_NO_WINDOW and GTK_WIDGET_COMPOSITE_CHILD. Also deprecate the type macros GTK_WIDGET_TYPE, GTK_OBJECT_TYPE_NAME and GTK_OBJECT_TYPE which have become redundant. Instances of GTK_WIDGET_TOPLEVEL are replaced with gtk_widget_is_toplevel, GTK_WIDGET_TYPE is replaced with G_OBJECT_TYPE, GTK_WIDGET_COMPOSITE_CHILD is replaced with use of the "composite-child" property and uses of GTK_WIDGET_NO_WINDOW are adjusted to use gtk_widget_get_has_window. Uses of GTK_WIDGET_SAVED_STATE and GTK_WIDGET_FLAGS inside GtkWidget are changed to direct flag usage. Documentation is updated to refer to gtk_widget_set_has_window and gtk_widget_get_has_window. Gail and tests are updated as well. Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=69872
* fix compile warningsBenjamin Otte2009-06-171-1/+2
| | | | | Fallout from running make CFLAGS="-Werror"; mostly missing casts and constness issues.
* Make GtkHandleBox work on multiple displaysMatthias Clasen2009-05-031-0/+1
|
* events return gboolean not gint. Change misnamedMichael Natterer2008-09-041-47/+46
| | | | | | | | | | | 2008-09-04 Michael Natterer <mitch@imendio.com> * gtk/gtkhandlebox.c: events return gboolean not gint. Change misnamed gtk_handle_box_button_changed() to gtk_handle_box_button_press(). Reindent static prototypes. svn path=/trunk/; revision=21286
* gtk/gtkaccellabel.c gtk/gtkcalendar.c gtk/gtkclist.c gtk/gtkentry.cMichael Natterer2008-08-121-2/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | 2008-08-12 Michael Natterer <mitch@imendio.com> * gtk/gtkaccellabel.c * gtk/gtkcalendar.c * gtk/gtkclist.c * gtk/gtkentry.c * gtk/gtkeventbox.c * gtk/gtkfilechooserbutton.c * gtk/gtkfilechooserdefault.c * gtk/gtkhandlebox.c * gtk/gtkhsv.c * gtk/gtkiconview.c * gtk/gtkimage.c * gtk/gtklayout.c * gtk/gtklistitem.c * gtk/gtkmenuitem.c * gtk/gtkmessagedialog.c * gtk/gtknotebook.c * gtk/gtkpaned.c * gtk/gtkpathbar.c * gtk/gtkplug.c * gtk/gtkprintunixdialog.c * gtk/gtkrange.c * gtk/gtkrecentchooserdefault.c * gtk/gtkruler.c * gtk/gtksocket.c * gtk/gtktext.c * gtk/gtktextview.c * gtk/gtktoolbar.c * gtk/gtktreeitem.c * gtk/gtktreeview.c * gtk/gtkviewport.c * gtk/gtkwin32embedwidget.c: chain up unconditionally in realize(), unrealize(), map(), unmap(), style_set(), key_press_event() and size_request() svn path=/trunk/; revision=21088
* consistently chain up using GTK_FOO_CLASS(parent_class)->bar(instance)Michael Natterer2008-08-121-2/+2
| | | | | | | | | | | 2008-08-12 Michael Natterer <mitch@imendio.com> * gtk/*.c: consistently chain up using GTK_FOO_CLASS(parent_class)->bar(instance) instead of (*GTK_FOO_CLASS(parent_class))->bar(instance). svn path=/trunk/; revision=21085