| Commit message (Collapse) | Author | Age | Files | Lines |
|
|
|
| |
Use the new builder dialog action support.
|
|
|
|
| |
Instead of Return value:
|
| |
|
| |
|
|
|
|
| |
Specifically, switch to using markdown syntax for sections.
|
| |
|
|
|
|
|
|
|
| |
Make the font chooser dialog use a headerbar
when desired.
https://bugzilla.gnome.org/show_bug.cgi?id=720059
|
|
|
|
|
| |
We'll keep this code around for now to not regress
on Windows, but avoid deprecation warnings.
|
|
|
|
|
|
|
|
|
|
|
| |
We rename the gtk_widget_class_bind_template_child{_internal}
macros by appending a _private to their name. Otherwise, it
would be too magic to pass the 'public' names as arguments,
but affect a member of the Private struct. At the same time,
Add two new macros with the old names,
gtk_widget_class_bind_template_child{_internal} that operate
on members of the instance struct.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
The macros and functions are inconsistently named, and are not tied to
the "template" concept - to the point that it seems plausible to use
them without setting the template.
The new naming scheme is as follows:
gtk_widget_class_bind_template_child_full
gtk_widget_class_bind_template_callback_full
With the convenience macros:
gtk_widget_class_bind_template_child
gtk_widget_class_bind_template_child_internal
gtk_widget_class_bind_template_callback
https://bugzilla.gnome.org/show_bug.cgi?id=700898
https://bugzilla.gnome.org/show_bug.cgi?id=700896
|
|
|
|
|
|
|
|
|
|
| |
Using an offset from the struct means you can have children in
both the public and private (via G_PRIVATE_OFFSET) parts of the
instance. It also matches the new private macros nicer.
https://bugzilla.gnome.org/show_bug.cgi?id=702563
Signed-off-by: Emmanuele Bassi <ebassi@gnome.org>
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
We've recently a number of classes wholly. For these cases,
move the headers and sources to gtk/deprecated/ and adjust
Makefiles and includes accordingly.
Affected classes:
GtkAction
GtkActionGroup
GtkActivatable
GtkIconFactory
GtkImageMenuItem
GtkRadioAction
GtkRecentAction
GtkStock
GtkToggleAction
GtkUIManager
|
|
|
|
| |
https://bugzilla.gnome.org/show_bug.cgi?id=702996
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
|
|
|
| |
Make the GtkFontChooser API similar to the Gtk{File,Recent,App}Chooser
APIs by introducing GtkFontChooser as an interface, that has a default
implementation in GtkFontChooserWidget.
https://bugzilla.gnome.org/show_bug.cgi?id=657627
|
|
|
|
| |
This is the expected behavior.
|
|
|
|
| |
This makes the string the same as in the app chooser dialog.
|
|
|
|
| |
Just committing these is easier than writing them up.
|
| |
|
|
|
|
| |
constructor
|
| |
|
| |
|
| |
|
|
gtkfontchooserdialog.[ch]
|