| Commit message (Collapse) | Author | Age | Files | Lines |
| |
|
|
|
|
|
|
|
|
|
| |
Previously, we wrapped all GtkCssShadowValues in a GtkCssShadowsValue,
even if it was just one shadow. This causes an unnecessary bloat in
css values.
Make each GtkCssShadowValue able to handle multiple shadows instead, and
use gtk_css_shadow_value* API everywhere.
|
| |
|
|
|
|
| |
And make sure it's included everywhere it's needed.
|
|
|
|
| |
This removes a lot of duplicated code.
|
|
|
|
| |
This removes a lot of duplicated code.
|
|
|
|
|
|
| |
The Vulkan renderer creates a fallback surface for each shadow
node, even if we end up not rendering anything to it. Avoiding
this is a nice optimization.
|
|
|
|
|
|
|
| |
... and make the icon rendering code use it.
This requires moving even more shadow renering code into GSK, but so be
it. At least the "shadows not implemented" warning is now gone!
|
|
|
|
| |
Use GskRoundedRect instead.
|
|
|
|
|
|
|
| |
This decouples actual background drawing from shadow drawing in the
snapshot case.
We also now create seperate nodes for shadows vs for backgrounds.
|
|
|
|
|
| |
This way we have an API to query extents per shadow and I want that in
the next patch.
|
|
|
|
|
|
|
|
|
| |
The spinner is a regular builtin image now. There is no need to go
through the shadows code manually anymore as regular items do get
shadows automatically.
This also allows simplifying the actual spinner drawing code so that it
actually works.
|
|
|
|
|
|
| |
We used to accept the same syntax for text-shadow and icon-shadow as
we accept for box-shadow. However, box-shadow does accept a spread and
the inset keyword while the others should not.
|
|
|
|
| |
The method returns the size of each side of a GtkCssShadowsValue.
|
|
|
|
|
|
|
|
|
|
| |
Adds conditional code paths to GdkCssShadowValue for painting outset
shadows, and allows shadows to be applied in two passes (first outset
then inset). This can be used to draw csd shadows in outer window
borders.
https://bugzilla.gnome.org/show_bug.cgi?id=695998
Signed-off-by: Rob Bradford <rob@linux.intel.com>
|
|
|
|
|
|
|
| |
This commit is essentially a large reorganization. Instead of all value
subtypes having their own compute function, there is the general
_gtk_css_value_compute() function that then calls a vfunc on the
subtype.
|
|
|
|
| |
... and enable transitions for the shadow properties.
|
|
|
|
|
|
| |
All the properties now are a GtkCssArrayValue of GtkCssSadowValue.
GtkCssArrayValue already does everything we want, so no need to
duplicate its funtionality.
|
|
|