summaryrefslogtreecommitdiff
path: root/gtk/gtkcalendar.c
Commit message (Collapse)AuthorAgeFilesLines
* dnd: Rename gtk_drag_begin_with_coordinatesMatthias Clasen2018-07-121-4/+4
| | | | | Now that the coordiate-less variant is gone, rename this back to the shorter gtk_drag_begin.
* gdk: Rename GdkDragContext to GdkDragMatthias Clasen2018-07-021-8/+8
| | | | | | | This is to go along with the newly introduced GdkDrop. This commit includes the necessary updates to the X11, Wayland and Broadway backends. Other backends have to be updated separately.
* widget: Remove time argument from drag_data_get() vfuncBenjamin Otte2018-06-181-4/+2
|
* dnd: Make drag-motion and drag-drop signals use GdkDropBenjamin Otte2018-06-181-22/+16
|
* dnd: Make drag-data-received use a GdkDropBenjamin Otte2018-06-181-18/+16
|
* widget: Make GtkWidgetClass::drag_leave() take a GdkDropBenjamin Otte2018-06-181-6/+3
| | | | Drag Contexts are on their way out!
* dnd: Get rid of gtk_drag_finish()Benjamin Otte2018-06-181-2/+2
| | | | It's just a wrapper around gdk_drag_finish(), so use that one instead.
* widget: Directly notify gestures of grabTimm Bäder2018-05-191-0/+2
| | | | | Since each widget has a list of event controllers now, we don't need to connect to ::grab-notify of the widget for every controller.
* eventcontrollerkey: Port to new API modelCarlos Garnacho2018-04-261-19/+5
|
* eventcontrollerscroll: Port to new API modelBenjamin Otte2018-04-261-7/+6
|
* draggesture: Port to new API modelBenjamin Otte2018-04-261-5/+4
|
* multipressgesture: Port to new API modelBenjamin Otte2018-04-261-5/+5
|
* snapshot: Redo debug messagesBenjamin Otte2018-04-241-2/+1
| | | | | Instead of every snapshot function having debug messages, have an explicit gtk_snapshot_push_debug() function that appends a debug node.
* gtkcalendar: Use key controller to track focus changesCarlos Garnacho2018-04-051-20/+19
|
* gtkcalendar: Stop using ::key-press-eventCarlos Garnacho2018-04-051-10/+19
| | | | Use GtkEventControllerKey for the task
* widget: Remove clip from size-allocate vfuncBenjamin Otte2018-04-051-4/+2
| | | | As the clip is no longer needed, get rid of it.
* GtkWidget: Start renaming widget->windowAlexander Larsson2018-03-201-1/+1
| | | | | | | | | | | | | | | This is an automated change doing these command: git sed -f g gtk_widget_set_has_window gtk_widget_set_has_surface git sed -f g gtk_widget_get_has_window gtk_widget_get_has_surface git sed -f g gtk_widget_set_parent_window gtk_widget_set_parent_surface git sed -f g gtk_widget_get_parent_window gtk_widget_get_parent_surface git sed -f g gtk_widget_set_window gtk_widget_set_surface git sed -f g gtk_widget_get_window gtk_widget_get_surface git sed -f g gtk_widget_register_window gtk_widget_register_surface git sed -f g gtk_widget_unregister_window gtk_widget_unregister_surface git checkout NEWS*
* calendar: Avoid warnings for new "%OB" formatMatthias Clasen2018-02-171-3/+21
| | | | | | Use the same code we have in gtk-3-22 to deal with strftime() not supporting %OB, and avoid compiler warnings for non-literal format strings.
* calendar: Use the new "%OB" format in strftime()Rafal Luzynski2018-02-131-2/+3
| | | | | | | | | | | Due to the recent changes introduced in glibc 2.27 "%OB" is the correct format to obtain a month name as used in the calendar header. The same rule has been working in BSD family (including OS X) since 1990s. This change is simple but makes GTK+ 4.x require glibc >= 2.27. If this requirement cannot be fulfilled then we must cherry-pick the full commit cbf118c from gtk-3-22 branch. Closes: #9
* The big versioning cleanupMatthias Clasen2018-02-061-30/+0
| | | | | | | Remove all the old 2.x and 3.x version annotations. GTK+ 4 is a new start, and from the perspective of a GTK+ 4 developer all these APIs have been around since the beginning.
* Replace gdk_threads_add_timeout* with g_timeout_add()Emmanuele Bassi2018-02-031-4/+4
| | | | | | | | | | | | | | | The main GDK thread lock is not portable and deprecated. The only reason why gdk_threads_add_timeout() and gdk_threads_add_timeout_full() exist is to allow invoking a callback with the GDK lock held, in case 3rd party libraries still use the deprecated gdk_threads_enter()/gdk_threads_leave() API. Since we're removing the GDK lock, and we're releasing a new major API, such code cannot exist any more; this means we can use the GLib API for installing timeout callbacks. https://bugzilla.gnome.org/show_bug.cgi?id=793124
* calendar: Stop using ::focus-out-eventMatthias Clasen2018-01-161-9/+12
| | | | Use the generic ::event signal.
* dnd: Pass device, not eventBenjamin Otte2017-12-121-8/+3
| | | | | You don't start a dnd operation with a device, you start it with an event.
* dnd: Remove button argument from drag_begin()Benjamin Otte2017-12-121-3/+1
| | | | It was unused.
* calendar: Stop using a legacy event handlerMatthias Clasen2017-12-101-27/+63
| | | | Replace the motion_notify handler by a drag gesture.
* calendar: Don't request drag data on every motion eventBenjamin Otte2017-12-111-1/+1
| | | | At least wait until we've received the previous one.
* dnd: Remove "delete" argument from gtk_drag_finish()Benjamin Otte2017-12-101-2/+2
| | | | | | | The argument is ignored by anything but X11. It's treated like suggested_action == MOVE. So do that in gtk_drag_finish(), too.
* dnd: Remove x/y coordinates from drag-data-receivedBenjamin Otte2017-12-051-4/+0
| | | | | | This is in preparation of using input streams to show that these coordinates aren't needed most of the time and can otherwise be saved during GtkWidget::drag-drop.
* gdk: Make GdkContentFormats immutableBenjamin Otte2017-11-201-1/+1
|
* contentformats: Rename GtkTargetListBenjamin Otte2017-11-201-3/+3
| | | | It's now called GdkContentsFormat
* Some more interningMatthias Clasen2017-11-181-3/+3
| | | | This avoids more strdups at startup.
* gtk: Intern css namesMatthias Clasen2017-11-171-1/+1
| | | | This avoids a bunch of strdups at startup.
* selection: Remove the info uintBenjamin Otte2017-11-161-5/+1
| | | | | | | | | Instead of allowing people to pass a uint user-data, insist on them comparing mime types. The user data was a uint instead of a pointer anyway, so uniqueness could not be guaranteed and it caused more issues than it was worth. And that's ignoring the fact that it basically wasn't used.
* gdk: Replace GDK_NONE with NULLBenjamin Otte2017-11-151-2/+2
|
* dnd: Make GtkDragDest and GtkDragSource use GtkTargetListBenjamin Otte2017-11-151-1/+1
| | | | | This gets rid of GtkTargetEntry in the API and consistently uses GtkTargetList.
* calendar: Fix for GTK4 changesBenjamin Otte2017-11-101-61/+29
|
* build: Enable -Wswitch-enum and -Wswitch-defaultBenjamin Otte2017-10-061-0/+2
| | | | | | | | | | | | | | | | | | | This patch makes that work using 1 of 2 options: 1. Add all missing enums to the switch statement or 2. Cast the switch argument to a uint to avoid having to do that (mostly for GdkEventType). I even found a bug while doing that: clearing a GtkImage with a surface did not notify thae surface property. The reason for enabling this flag even though it is tedious at times is that it is very useful when adding values to an enum, because it makes GTK immediately warn about all the switch statements where this enum is relevant. And I expect changes to enums to be frequent during the GTK4 development cycle.
* gtkcalendar: Use scroll event controllerCarlos Garnacho2017-09-191-25/+27
|
* calendar: Update to using GdkEvent APICarlos Garnacho2017-09-191-9/+20
|
* calendar: Stop using ::button-{press,release}-eventTimm Bäder2017-09-131-39/+53
|
* Calendar: Add default case to appease CoverityDaniel Boles2017-08-011-0/+3
| | | | | | | | | | CID 1432024 (#1 of 1): Uninitialized scalar variable (UNINIT) 2. uninit_use_in_call: Using uninitialized value rect.x when calling calendar_arrow_rectangle. Add a default case to the switch which will bail out with g_assert_not_reached(), which should reassure Coverity that the method is always called with a valid value that is handled in the switch.
* widget: Add baseline and out_clip parameters to size-allocateTimm Bäder2017-07-191-7/+8
| | | | | | | | | | | Since setting a clip is mandatory for almost all widgets, we can as well change the size-allocate signature to include a out_clip parameter, just like GtkCssGadget did. And since we now always propagate baselines, we might as well pass that one on to size-allocate. This way we can also make sure to transform the clip returned from size-allocate to parent-coordinates, i.e. the same coordinate space priv->allocation is in.
* calendar: Remove all input windowsTimm Bäder2017-07-191-368/+23
| | | | and simultaneously fix input! \o/
* calendar: Remove style propertiesTimm Bäder2017-07-191-56/+3
| | | | | Hardcode the default values until someone comes and fixes the actual widget.
* calendar: Remove custom css background and border drawingTimm Bäder2017-07-191-15/+3
|
* Remove calls to gtk_widget_set_allocationTimm Bäder2017-07-191-1/+0
| | | | gtk_widget_size_allocate_with_baselines does it automatically now.
* set clip of more widgetsTimm Bäder2017-07-191-0/+2
|
* gtk: Mass delete all GtkWidget event mask APICarlos Garnacho2017-05-251-9/+2
| | | | | | | | | | We now rely on toplevels receiving and forwarding all the events the windowing should be able to handle. Event masks are no longer a way to determine whether an event is deliverable ot a widget. Events will always be delivered in the three captured/target/bubbled phases, widgets can now just attach GtkEventControllers and let those handle the events.
* calendar: Fix else branch indentationsTimm Bäder2017-03-181-2/+2
|
* snapshot: Rename gtk_snapshot_translate_2d()Benjamin Otte2017-01-131-14/+14
| | | | It's now called gtk_snapshot_offset().