summaryrefslogtreecommitdiff
path: root/gtk/gtkactionhelper.c
Commit message (Collapse)AuthorAgeFilesLines
* gtk: Use the new debug macrosMatthias Clasen2022-09-231-13/+18
|
* Remove all nicks and blurbs from param specsSophie Herold2022-05-111-3/+3
| | | | | | | | Those property features don't seem to be in use anywhere. They are redundant since the docs cover the same information and more. They also created unnecessary translation work. Closes #4904
* gtk: Clean up docs syntaxMatthias Clasen2021-05-221-5/+5
| | | | Replace leftover gtk-doc syntax (#Type) with backquotes.
* actionhelper: Add a getterMatthias Clasen2020-09-011-0/+9
| | | | Add a getter for the GtkActionHelper:role property.
* Replace "gchar" with "char"Benjamin Otte2020-07-251-7/+7
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-1/+1
|
* actionmuxer: Port internal usersMatthias Clasen2020-07-201-7/+9
| | | | | | Port all internal users of the action muxer from the GActionGroup interface to the new action muxer apis.
* Privatize popover menu piecesMatthias Clasen2019-11-111-1/+1
| | | | | | Don't allow manual creation of popover menus anymore. This lets us also make GtkModelButton private
* Rename a bunch of private headersMatthias Clasen2019-06-101-1/+1
| | | | | We want to follow the convention that all private headers have names ending in private.h
* Rename GtkActionHelper private headerEmmanuele Bassi2018-02-021-2/+1
| | | | Follow the naming scheme for private headers.
* GtkActionHelper: Remove unnecessary NULL checkDebarshi Ray2017-06-131-10/+5
| | | | | | | | This NULL check has existed since commit 652f16dd985dbc1b, when GtkActionHelper was first introduced, but so has the assertion at the top to ensure the validity of 'widget'. https://bugzilla.gnome.org/show_bug.cgi?id=783587
* GtkActionHelper: Allow a NULL action-name to unset the previous GActionDebarshi Ray2017-06-131-28/+38
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=783587
* GtkActionHelper: Change a message to a warningMatthew Leeds2016-06-191-6/+6
| | | | | | | | It's almost certainly a programmer error if an action isn't activatable because its target and parameter type don't match. This commit changes the existing g_message to a g_warning. https://bugzilla.gnome.org/show_bug.cgi?id=767705
* Better debug messages for actionsMatthias Clasen2016-03-111-15/+17
| | | | | Unify the debug messages between actionhelper and menutracker, and add some more context to some of them.
* GtkActionHelper: Avoid null deref in debug codeMatthias Clasen2015-07-171-1/+1
|
* gtkwindow: Use actions from focused widget to activate accelCarlos Soriano2014-12-081-1/+1
| | | | | | | | | | | | | | | Currently we only take into account the window GActionGroup for activating the accels. However, the application could have some custom GActionGroup in the chain of focused widgets that could want to activate some action if some accel is activated while that widget is focused. To allow applications to set accels on widgets that use custom GActionGroups, simply use the muxer of the focused widget, which already contains the actions of the parents. https://bugzilla.gnome.org/show_bug.cgi?id=740682
* GtkModelButton: Don't require an explicit roleMatthias Clasen2014-10-291-3/+38
| | | | | When we have an action-name, we can deduce the role from the action that is looked up by the action helper.
* GtkActionHelper: add some debugging outputRyan Lortie2014-08-031-2/+32
| | | | | | | | | | Introduce a new debug category "actions" and write some messages from GtkActionHelper about if we can find the actions or not. We will probably soon want to add some similar messages to GtkMenuTrackerItem. https://bugzilla.gnome.org/show_bug.cgi?id=733965
* Simplify GtkActionHelperRyan Lortie2014-01-081-130/+19
| | | | | | | Now that the last GMenuModel-based user of GtkActionHelper is gone, we can substantially simplify it. https://bugzilla.gnome.org/show_bug.cgi?id=721836
* action stuff: stop abusing GLib's namespaceRyan Lortie2013-05-131-33/+33
| | | | | | | | | | | Rename our internal GActionMuxer, GActionObserver and GActionObservable classes and interfaces to have names in our own namespace. These classes were originally intended for GIO but turned out to be too special-purpose to be useful there, so we never made them public API but have just been copying them around (without bothering to properly rename them). Now that other people will be copying them out of Gtk, it's even more important to prevent this namespace abuse from spreading further.
* GtkActionHelper: Fix a copy-paste errorMatthias Clasen2012-11-291-1/+1
| | | | | | The code clearly meant to reset action->active here. This was found by Coverity.
* GtkActionHelper: two small fixups in _set_target_value()Ryan Lortie2012-08-221-1/+8
| | | | | | | First, ensure we always consume floating values, as documented. Second (and more serious), don't try to query the action if the action name is not set yet. This will cause crashes...
* introduce private GtkActionHelperRyan Lortie2012-08-201-0/+631
The current process of implementing GActionObserver is annoying and the GSimpleActionObserver interface leaves a lot to be desired. Introduce a new class, GtkActionHelper that gives you pretty much everything you'd want to do as an implementor of GtkActionable. The GtkActionHelper also features an "application" mode that is not associated with a particular GtkWidget but rather with whatever widget happens to be the active window of the given GtkApplication at a particular point in time. This will be useful for the Mac OS menubar.