summaryrefslogtreecommitdiff
path: root/docs/tools
Commit message (Collapse)AuthorAgeFilesLines
* aboutdialog: Improve example imageMatthias Clasen2021-03-112-3/+11
| | | | Use our logo, and update the copyright years.
* docs: Add dialogs to the galleryMatthias Clasen2021-03-111-0/+31
|
* docs: Split images for check and radio buttonsMatthias Clasen2021-03-111-3/+17
| | | | | Its the same widget, but two images fit better in the gallery, and will be easier to use as example images in the docs.
* docs: Improve the togglebutton imageMatthias Clasen2021-03-111-2/+10
| | | | Make it actually show toggles.
* gtk: Remove GtkFileChooserButtonBenjamin Otte2020-12-031-46/+0
| | | | ... as discussed in the meeting.
* docs: Add GtkOverlay to the widget galleryMatthias Clasen2020-10-271-0/+40
|
* docs: Add box, grid and center box to the galleryMatthias Clasen2020-10-271-1/+164
|
* docs: Add GtkDrawingArea to the galleryMatthias Clasen2020-10-261-2/+186
|
* docs: Add GtkShortcutsWindow to the widget galleryMatthias Clasen2020-10-264-1/+147
|
* docs: Add GtkPopoverMenu to the widget galleryMatthias Clasen2020-10-261-0/+64
|
* docs: Add GtkPopover to the widget galleryMatthias Clasen2020-10-261-0/+24
|
* docs: Add GtkPopoverMenuBar to the galleryMatthias Clasen2020-10-261-0/+52
|
* docs: Add GtkExpander to the galleryMatthias Clasen2020-10-261-0/+14
|
* docs: Add GtkEmojiChooser to the galleryMatthias Clasen2020-10-263-3/+46
| | | | | To make this possible enable the doc shooter to take screenshots of popovers.
* docs: Improve the GtkStackSidebar gallery imageMatthias Clasen2020-10-251-1/+2
|
* docs: Fix the GtkVolumeButton gallery imageMatthias Clasen2020-10-251-16/+9
| | | | | Give up on showing the popup, we don't do that for other buttons either.
* docs: Add GtkCalendar to the galleryMatthias Clasen2020-10-251-0/+20
| | | | It has been missing far too long.
* docs: Improve the GtkMediaControls gallery imageMatthias Clasen2020-10-251-2/+10
|
* docs: Improve the GtkVideo gallery imageMatthias Clasen2020-10-253-5/+27
|
* docs: Shrink the editable label gallery imageMatthias Clasen2020-10-251-1/+1
| | | | Makes it fit better with the other entries.
* docs: Work around GtkPicture growingMatthias Clasen2020-10-251-1/+6
| | | | | Make the GtkPicture gallery image stay within its limits, by overpowering its request mode.
* docs: Add GtkWindowControls to the galleryMatthias Clasen2020-10-251-0/+21
|
* doc shooter: Remove radio button remnantsMatthias Clasen2020-08-311-20/+0
|
* doc shooter: Drop radio buttonsMatthias Clasen2020-08-301-5/+22
| | | | Instead, show grouped checkbuttons.
* build: The doc shooter works without x11 nowMatthias Clasen2020-08-301-1/+1
| | | | | No need to restrict the build to just x11. We're not using pixmaps anymore.
* Drop GtkAccelLabelMatthias Clasen2020-08-041-22/+0
| | | | We no longer use this widget anywhere.
* docs: Add a gallery image for GtkDropDownMatthias Clasen2020-08-041-0/+14
|
* docs: Add a gallery image for GtkEditableLabelMatthias Clasen2020-08-041-0/+22
|
* docs: Add gallery image for GtkPasswordEntryMatthias Clasen2020-08-041-0/+18
|
* docs: Avoid focus in gallery imagesMatthias Clasen2020-08-041-0/+9
| | | | | | Seeing focus rectangles and selections in these images is a distraction, and we used to avoid it. Bring that back.
* docs: Improve the gallery image for scalesMatthias Clasen2020-08-041-6/+11
|
* docs: Add gallery images for some more widgetsMatthias Clasen2020-08-041-0/+70
| | | | This adds GtkPicture, GtkVideo, GtkMediaControls.
* docs: Redo the doc shooter codeMatthias Clasen2020-08-045-346/+241
| | | | | | | Steal snapshotting code from the reftests to make this work again. Other changes here: catch up with container removal.
* Replace "gchar" with "char"Benjamin Otte2020-07-252-2/+2
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-2/+2
|
* scrolledwindow: Don't take adjustments in new()Matthias Clasen2020-06-241-1/+1
| | | | | | | In 99.9% of all cases, these are just NULL, NULL. So just do away with these arguments, people can use the setters for the rare cases where they want the scrolled window to use a different adjustment.
* Replace most remaining uses of container apiMatthias Clasen2020-05-111-93/+93
| | | | These are all on GtkBox or enumerating children.
* Don't use container api on GtkListBoxMatthias Clasen2020-05-111-4/+4
|
* paned: Redo the apiMatthias Clasen2020-05-111-16/+26
| | | | | | | | | | | | This commit is porting GtkPaned to be derived from GtkWidget instead of GtkContainer, while adding start-child and end-child properties. The existing properties are renamed to follow the start/end naming scheme, and we add proper getters and setters. Update all users. See #2719
* Use gtk_window_destroyMatthias Clasen2020-05-111-1/+1
| | | | | Replace calls to gtk_widget_destroy on windows with gtk_window_destroy.
* docs: Fixup for an uninitialized variableMatthias Clasen2020-05-041-1/+1
|
* Use gtk_combo_box_set_child throughoutMatthias Clasen2020-05-041-5/+5
|
* Use gtk_window_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add on windows by gtk_window_set_child.
* Use gtk_button_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add on buttons by gtk_button_set_child.
* Use gtk_scrolled_window_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add on popovers by gtk_scrolled_window_set_child.
* Use gtk_frame_set_child throughoutMatthias Clasen2020-05-041-1/+1
| | | | | Replace all uses of gtk_container_add for frames with gtk_frame_set_child.
* headerbar: Remove user-settable titleAlexander Mikhaylenko2020-05-011-1/+1
| | | | | | | | Use window title, or custom title widget if it's set. Remove 'title' property. Update demos and tests to set the title on the window instead of headerbar.
* headerbar: Remove subtitleAlexander Mikhaylenko2020-05-011-1/+0
| | | | | Also remove the box containing title and subtitle, as there's only one label now.
* frame: Drop shadow-typeMatthias Clasen2020-04-171-18/+4
| | | | | Frames that don't draw frames are not very useful, so just drop the shadow-type property.
* Use gtk_widget_add/remove_css_class moreMatthias Clasen2020-04-101-1/+1
| | | | | | Replace most uses of gtk_style_context_add/remove_class by the new APIs. The only remaining uses of the old API are in save/restore situations.