| Commit message (Collapse) | Author | Age | Files | Lines |
| |
|
| |
|
| |
|
|
|
|
| |
Because it's FALSE in virtually all use cases.
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
| |
Also remove mentions of the old text convenience API from the docs,
and point to GtkComboBoxText instead.
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
GtkComboBox now sports a construct-only "has-entry" property which
decides if it uses a GtkEntry to allow additional user input. Also
it has a new "entry-text-column" to fetch strings for the entry
from the model.
This patch deprecates the GtkComboBoxEntry and updates the rest of GTK+
to use the new semantics on GtkComboBox instead.
GtkComboBoxEntry will be removed altogether before GTK+ 3, in a
later commit.
|
|
|
|
| |
This function is going away.
|
|
|
|
|
|
|
|
|
|
| |
The ownership of the return value for gdk_pixbuf_get_from_window() and
gdk_pixbuf_get_from_surface() was determined by the first argument.
Because that is an ugly design and the functions are new to GTK3, we
decided to adapt them.
And that adaptation was quite easy since almost no one passses anything
but NULL as the first argument.
|
| |
|
|
|
|
|
|
| |
As gtk_adjustment_new() returns a GtkAdjustment* now
https://bugzilla.gnome.org/show_bug.cgi?id=630731
|
|
|
|
|
| |
Fix compile warning and use cairo_paint() instead of querying the widget
size and cairo_fill()ing it.
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
It doesn't make sense to keep them separate as GtkSizeRequest requires a
GtkWidget and GtkWidget implements GtkSizeRequest, so you can never have
one without the other.
It also makes the code a lot easier because no casts are required when
calling functions.
Also, the names would translate to gtk_widget_get_width() and people
agreed that this would be a too generic name, so a "preferred" was added
to the names.
So this patch moves the functions:
gtk_size_request_get_request_mode() => gtk_widget_get_request_mode()
gtk_size_request_get_width() => gtk_widget_get_preferred_width()
gtk_size_request_get_height() => gtk_widget_get_preferred_height()
gtk_size_request_get_size() => gtk_widget_get_preferred_size()
gtk_size_request_get_width_for_height() =>
gtk_widget_get_preferred_width_for_height()
gtk_size_request_get_height_for_width() =>
gtk_widget_get_preferred_height_for_width()
... and moves the corresponding vfuncs to the GtkWidgetClass.
The patch also renames the implementations of the vfuncs in widgets to
include the word "preferrred".
|
| |
|
|
|
|
|
|
| |
Large patch, but just renaming.
Indentation should still mostly be correct because I took care of
keeping the indentation for this function name.
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
| |
The Colormap argument needed to be removed, so the renaming is just a
side effect.
|
| |
|
| |
|
|
|
|
|
| |
This requires changes to all the offscreen surface getters that used to
return a GdkPixmap before.
|
|
|
|
|
|
|
|
| |
With gtk_show_uri, global configurability of link activation has
moved to GIO/gvfs. For local overrides, GtkLinkButton has the ::clicked
signal, and GtkAboutDialog gets an ::activate-link signal.
Bug 339745
|
|
|
|
| |
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=323904
|
| |
|
|
|
|
|
|
|
| |
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=629598
Signed-off-by: Javier Jardón <jjardon@gnome.org>
Signed-off-by: Tristan Van Berkom <tristanvb@openismus.com>
|
|
|
|
| |
Use gtk_size_request_get_size() instead
|
|
|
|
|
|
|
|
| |
Rename the gtk_major_version() etc functions I introduced yesterday to
start with gtk_get. Avoids misleading results in client programs whose
developers that don't notice the change or the compiler warnings, and
when recompiling against gtk3 then use the function addresses as the
version numbers.
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
The keysyms create a lot of potential namespace conflicts for
C, and are especially problematic for introspection, where we take
constants into the namespace, so GDK_Display conflicts with GdkDisplay.
For C application compatiblity, add gdkkeysyms-compat.h which uses
the old names.
Just one user in GTK+ continues to use gdkkeysyms-compat.h, which is
the gtkimcontextsimple.c, since porting that requires porting more
custom Perl code.
|
|
|
|
|
|
| |
Having variables exported from a DLL is slightly painful and
potentially error-prone on Windows, so let's try get rid of them now
when we can. Starting with these.
|
| |
|
|
|
|
| |
Commit d433a606111d89727530f71d7b956b dropped this API.
|
|
|
|
|
|
| |
Rename the ::orientation property of GtkIconView to item-orientation,
which is both clearer and avoids the conflict with the orientation
property of GtkOrientable implementations.
|
| |
|
| |
|