summaryrefslogtreecommitdiff
path: root/testsuite/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/gtk/Makefile.am')
-rw-r--r--testsuite/gtk/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/testsuite/gtk/Makefile.am b/testsuite/gtk/Makefile.am
index 52aacfa1ab..728c37946e 100644
--- a/testsuite/gtk/Makefile.am
+++ b/testsuite/gtk/Makefile.am
@@ -34,6 +34,7 @@ TEST_PROGS += \
adjustment \
bitmask \
builder \
+ builderparser \
cellarea \
check-icon-names \
clipboard \
@@ -161,10 +162,22 @@ test_icontheme = \
icons2/index.theme \
$(NULL)
+test_ui = \
+ ui/test1.ui \
+ ui/test1.expected \
+ ui/test2.ui \
+ ui/test2.expected \
+ ui/test3.ui \
+ ui/test3.expected \
+ ui/test4.ui \
+ ui/test4.expected \
+ $(NULL)
+
EXTRA_DIST += \
file-chooser-test-dir/empty \
file-chooser-test-dir/text.txt \
$(test_icontheme) \
+ $(test_ui) \
$(NULL)
GTK_GSETTINGS_SCHEMAS = \
@@ -186,7 +199,7 @@ all-am: gschemas.compiled
if BUILDOPT_INSTALL_TESTS
insttestdir = $(libexecdir)/installed-tests/$(PACKAGE)
insttest_PROGRAMS = $(TEST_PROGS)
-nobase_insttest_DATA = $(test_icontheme)
+nobase_insttest_DATA = $(test_icontheme) $(test_ui)
%.test: %$(EXEEXT) Makefile
$(AM_V_GEN) (echo '[Test]' > $@.tmp; \