summaryrefslogtreecommitdiff
path: root/testsuite/gdk/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/gdk/meson.build')
-rw-r--r--testsuite/gdk/meson.build44
1 files changed, 24 insertions, 20 deletions
diff --git a/testsuite/gdk/meson.build b/testsuite/gdk/meson.build
index c259be1f06..e3b2e8869a 100644
--- a/testsuite/gdk/meson.build
+++ b/testsuite/gdk/meson.build
@@ -10,36 +10,39 @@ clipboard_client = executable('clipboard-client',
install_dir: testexecdir)
tests = [
- 'array',
- 'cairo',
- 'clipboard',
- 'contentformats',
- 'contentserializer',
- 'cursor',
- 'display',
- 'displaymanager',
- 'encoding',
- 'keysyms',
- 'memorytexture',
- 'pixbuf',
- 'rectangle',
- 'rgba',
- 'seat',
- 'texture',
- 'texture-threads',
+ { 'name': 'array' },
+ { 'name': 'cairo' },
+ { 'name': 'clipboard', 'parallel': false, },
+ { 'name': 'contentformats' },
+ { 'name': 'contentserializer' },
+ { 'name': 'cursor' },
+ { 'name': 'display' },
+ { 'name': 'displaymanager' },
+ { 'name': 'encoding' },
+ { 'name': 'keysyms' },
+ { 'name': 'memorytexture' },
+ { 'name': 'pixbuf' },
+ { 'name': 'rectangle' },
+ { 'name': 'rgba' },
+ { 'name': 'seat' },
+ { 'name': 'texture' },
+ { 'name': 'texture-threads' },
]
foreach t : tests
- test_exe = executable(t, '@0@.c'.format(t),
+ test_name = t.get('name')
+ test_exe = executable(test_name,
+ sources: '@0@.c'.format(test_name),
c_args: common_cflags,
dependencies: libgtk_dep,
install: get_option('install-tests'),
install_dir: testexecdir,
)
- test(t, test_exe,
+ test(test_name, test_exe,
args: [ '--tap', '-k' ],
protocol: 'tap',
+ is_parallel: t.get('parallel', false),
env: [
'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
@@ -76,9 +79,10 @@ endforeach
if get_option('install-tests')
foreach t : tests
+ test_name = t.get('name')
test_cdata = configuration_data()
test_cdata.set('testexecdir', testexecdir)
- test_cdata.set('test', t)
+ test_cdata.set('test', test_name)
configure_file(input: 'gdk.test.in',
output: '@0@.test'.format(t),
configuration: test_cdata,