summaryrefslogtreecommitdiff
path: root/modules/engines/pixbuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/engines/pixbuf/Makefile.am')
-rw-r--r--modules/engines/pixbuf/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/engines/pixbuf/Makefile.am b/modules/engines/pixbuf/Makefile.am
index 9a0ded4b0f..27ebd8e37b 100644
--- a/modules/engines/pixbuf/Makefile.am
+++ b/modules/engines/pixbuf/Makefile.am
@@ -1,3 +1,7 @@
+if OS_WIN32
+no_undefined = -no-undefined
+endif
+
INCLUDES = $(GTK_CFLAGS)
enginedir = $(libdir)/gtk-2.0/$(GTK_VERSION)/engines
@@ -13,7 +17,7 @@ libpixmap_la_SOURCES = \
pixbuf-style.h \
pixbuf.h
-libpixmap_la_LDFLAGS = -avoid-version -module
+libpixmap_la_LDFLAGS = -avoid-version -module $(no_undefined)
libpixmap_la_LIBADD = $(GTK_LIBS)
dist-hook: