summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index b5c4fa166e..9500d85d86 100644
--- a/meson.build
+++ b/meson.build
@@ -621,14 +621,16 @@ subdir('gdk')
subdir('gsk')
subdir('gtk')
subdir('modules')
-if get_option('demos')
- subdir('demos')
- subdir('examples')
-endif
if get_option('build-tests')
subdir('tests')
subdir('testsuite')
endif
+if get_option('demos')
+ subdir('demos')
+endif
+if get_option('build-examples')
+ subdir('examples')
+endif
# config.h
configure_file(input: 'config.h.meson',