summaryrefslogtreecommitdiff
path: root/gtk/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/meson.build')
-rw-r--r--gtk/meson.build46
1 files changed, 25 insertions, 21 deletions
diff --git a/gtk/meson.build b/gtk/meson.build
index a0b3932d57..fa1f7b2908 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -596,8 +596,10 @@ proto_sources = [
]
im_wayland_sources = files('gtkimcontextwayland.c')
-wayland_scanner = find_program('wayland-scanner')
-genprotocols = find_program('../gdk/wayland/genprotocolfiles.py')
+if wayland_enabled
+ wayland_scanner = find_program('wayland-scanner')
+ genprotocols = find_program('../gdk/wayland/genprotocolfiles.py')
+endif
foreach p: proto_sources
proto_name = p.get(0)
@@ -612,25 +614,27 @@ foreach p: proto_sources
input = join_paths(proto_dir, '@0@/@1@/@2@.xml'.format(proto_stability, proto_name, output_base))
endif
- im_wayland_sources += custom_target('@0@ client header'.format(output_base),
- input: input,
- output: '@0@-client-protocol.h'.format(output_base),
- command: [
- genprotocols,
- wayland_scanner,
- '@INPUT@', '@OUTPUT@',
- 'client-header',
- ])
-
- im_wayland_sources += custom_target('@0@ source'.format(output_base),
- input: input,
- output: '@0@-protocol.c'.format(output_base),
- command: [
- genprotocols,
- wayland_scanner,
- '@INPUT@', '@OUTPUT@',
- 'code',
- ])
+ if wayland_enabled
+ im_wayland_sources += custom_target('@0@ client header'.format(output_base),
+ input: input,
+ output: '@0@-client-protocol.h'.format(output_base),
+ command: [
+ genprotocols,
+ wayland_scanner,
+ '@INPUT@', '@OUTPUT@',
+ 'client-header',
+ ])
+
+ im_wayland_sources += custom_target('@0@ source'.format(output_base),
+ input: input,
+ output: '@0@-protocol.c'.format(output_base),
+ command: [
+ genprotocols,
+ wayland_scanner,
+ '@INPUT@', '@OUTPUT@',
+ 'code',
+ ])
+ endif
endforeach
if os_unix