summaryrefslogtreecommitdiff
path: root/gdk/wayland/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdk/wayland/Makefile.am')
-rw-r--r--gdk/wayland/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gdk/wayland/Makefile.am b/gdk/wayland/Makefile.am
index 08ed75ca77..0ad465f6aa 100644
--- a/gdk/wayland/Makefile.am
+++ b/gdk/wayland/Makefile.am
@@ -10,6 +10,7 @@ AM_CPPFLAGS = \
-DGDK_COMPILATION \
-I$(top_srcdir) \
-I$(top_srcdir)/gdk \
+ -I$(top_srcdir)/gdk/wayland/cursor \
-I$(top_builddir)/gdk \
$(GDK_HIDDEN_VISIBILITY_CFLAGS) \
$(GTK_DEBUG_FLAGS) \
@@ -77,6 +78,14 @@ libgdk_wayland_la_SOURCES = \
wm-button-layout-translation.c \
wm-button-layout-translation.h
+libgdk_wayland_la_SOURCES += \
+ cursor/os-compatibility.c \
+ cursor/os-compatibility.h \
+ cursor/wayland-cursor.c \
+ cursor/wayland-cursor.h \
+ cursor/xcursor.c \
+ cursor/xcursor.h
+
libgdkinclude_HEADERS = \
gdkwayland.h